
 

 

 

 
 

 



 

 

 

PCB Artist Layout Software 
 

This page is not intended to replace the Design Tutorial in PCB Artist, but to clarify important items for users.  The 
Design Tutorial is found in the PCB Artist application itself.  It is accessible from the main menu under Help>Design 
Tutorial.   

Technical support is available at Layouthelp@AdvancedPCB.com 
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PCB Artist Online Library Guide 
Access the PCB Artist™ Online Library by clicking here.  

 
PCB Artist Version: 

• To determine your current version, go to Help>About PCB Artist™. Version 1.2.2 

is required at the minimum to use the online library. 

• To download the latest patch, go to Help>Check for Updates and push the Check 

for Updates Now at the bottom of that dialog. 

o It is also good practice to make sure that the "When to Check" toggle is 

set to "Once A Day" or "Every time I Start". 

o A web page will launch to the update page. There will be a link to the 

latest full installation and the latest Patch. If your revision is older than 

both, you must install both. First the full installation, then the patch. 

o Exit PCB Artist™ before installing either. 

• If your version of PCB Artist does not show the Check for Updates option under 

the Help menu, the version pre-dates that patch system. It is best to download 

the latest complete install from https://www.advancedpcb.com/en-us/tools/pcb-

artist-software/. 

 
Searching the Online Library: 

• All parts in the database are referenced by Part Number and Manufacture 

primarily. 

• Digi-Key part numbers are available for a large percentage of parts, but 

manufacturer part number on every part in the library. 

• Searches with Attributes can help in filtering, but attributes are not available for 

all parts. 

• For a comprehensive search by attribute, it is recommended to search on the 

manufacturer or distributor's search engine. This will result in a list of part 

numbers of suitable parts that can be used to search the Online Library. 

• Be aware that new designers can be deceived by common names that do not 

indicate similar packages. For example, many packages are called SOIC-16 and 

they are usually not compatible with other SOIC-16 footprints. 

• Search Filters can be set to Starts With, Contains and Is Exactly. For the best 

results, it is often advisable to use Contains. 

• The Reset button clears all fields back to default. 

• The Clear Text Button will clear entered text but not filter and Attribute settings. 

• The Attributes fields require that an attribute is chosen on the left and that search 

text be entered on the right text blank. If not, the search will not proceed. Here is 

an example of a valid search: 

https://www.my4pcb.com/artistonlinelibrary/Default.aspx
https://www.advancedpcb.com/en-us/tools/pcb-artist-software/
https://www.advancedpcb.com/en-us/tools/pcb-artist-software/


 

 

 

 

• Searches will display a maximum of 15 parts per page. Links are available at the 

bottom of the page to continue to other pages of the search. 

• Click on a part in the list to see its available details. 

• In the details page, there is a Download and Email To button for retrieving the 

part. 

o The Download button will immediately download the part. It can be saved 

to any directory or to your desktop. 

o The Email To button requires that an email address is entered in the text 

box to the right. Enter your email button in that box first and then push the 

Email To button. When the email arrives, the part will be an attachment to 

that email. Save it to any directory or to your desktop. 

 
If The Part is Not Found: 

• Make sure the search was made from the manufacture's part number from the 

Part Number search field with the filter set to Contains. 

• There are over a quarter million parts in the online library, but there are tens of 

millions of parts/packages in circulation. 

• It takes less than 5 minutes to make most parts in PCB Artist. It is not efficient to 

spend much more time searching for parts; the part could have been made 

already. 

• For a tutorial in making a part, go to Help>Tutorials>Part Creation Tutorial in the 

PCB Artist main menu. 

o Typically, a part such as a microcontroller is very easy to create because 

the wizards can be used to make all three parts. The PCB Symbol for a 

microcontroller can be created in the wizard in about 30 seconds once 

you have experienced creating 2 or 3 of them. 

• The Frequently Asked Questions document also has a topic link in that 

section that details how to manually create parts that cannot be created in the 

wizard (such as switches and connectors, which have no common form factor for 

the wizards). Manual part creation is covered in the "How Do I Create a 

Connector" Or "Other Manually Created Parts" topic link, just under the 

walkthroughs of the three symbol wizards. 

 
 
 
 
 
 
 



 

 

 

Importing the Part to PCB Artist: 
• From this point the part has been downloaded from the Online Library to a 

directory or to your desktop. 

• The file will have the .palib extension. That file is a medium for transporting, in 

one package, the schematic symbol(s), PCB symbol(s) and the component itself 

that defines the relationship and pins of the symbols. 

• To bring the part into PCB Artist, simply select the .palib file and drag it into PCB 

Artist. 

• When the file is dropped onto PCB Artist, the application will take from that file 

the symbols for the part and put them into the schematic, PCB symbol and 

component libraries. 

• The contents of the .palib file will be imported to the following directories: 

o The schematic symbol(s) will go to the library $Download.ssl. 

o The PCB symbol(s) will go to the library $Download.psl. 

o The Component will go to the library $Download.cml. 

o This is the import dialog: 

 
• If the part is to be immediately used, the application may not immediately 

recognize the new symbols in the library. To have the application rescan the 

libraries to find the new parts, change the current working library to [All 

Libraries]. This will cause the application to scan and re-index all libraries and 



 

 

 

find the new parts. This only needs to be done once in any of these three 

locations: 

 

From the Library Manager, change this drop-down menu to [All Libraries]: 

 
  

• From the Interaction Bar (which is brought up with F9), change this drop-down 

menu to [All Libraries]: 

 
 

From the Add Component dialog, change this drop-down menu to [All Libraries]: 

 



 

 

 

 
• From any of the three dialogs, change your library to $Downloaded.psl to use the 

newly downloaded part. 

 
• Once the part is imported, the .palib file can be discarded or filed in a folder. 

 
Verify the Part: 

• It is recommended to verify all parts before use, regardless of the source the part 

came from. 

• Finding the Names of the Symbols in the Component. 

o Bring up the Library Manager, click on the Component Tab at the top of 

that dialog and change the Library drop down menu at the top of the 

dialog to $Downloaded.psl. 

o In the left of the dialog there will be a list of the components in that 

library. Select the part you downloaded. 

o In the right-hand side of the dialog, the name of the symbols the 

component uses are listed. Note those symbol names for later reference, 

they must also be verified. 

 



 

 

 

• Verifying the Component. 

o Bring up the Library Manager, click on the Component Tab at the top of 

that dialog and change the library to $Downloaded.psl. 

o In the left of the dialog there will be a list of the components in that 

library. Select the part you downloaded. 

o Click the Edit button in the central column of buttons. 

o This is the Component Editor. In this screen you can verify the pins 

mapping, the logic names and any implied nets assigned to pins. Multiple 

gate pin mapping is also done on this screen. 

• The Gate Name is used to identify individual schematic symbols on parts that 

have multiple schematic symbols (referred to as gates). Most symbols will not 

have multiple gates. 

• The Sch Symbol Name column identifies the schematic symbol for that gate. 

• The Sch Symbol Terminal Name column is where logic names can be entered for 

the part. If none are assigned, they can be entered here and saved with the part. 

• The Sch Terminal Number, PCB Symbol Pad Number and the Component Pin 

Name/Number columns map the relationships of the pins between the 

symbols. This should be confirmed. 

• The Net (Class) Name can provide an automatic implied net for a particular 

pin. In this column a pin can be added to the GND net, for example. Be aware 

there are sometimes implications with specific implied nets that can affect future 

designs. For example, if a net is assigned to GND, and is later added to a design 

where the ground net is named AGND. In that case the GND net will be a new 

net and not connected to AGND. 

• For more information on the Net (Class) column and it options for creating 

implied nets and also implied net classes, go to Help>Contents in the 

application. In the upper left, click on the Index tab and search for the term 

Library Components. 

 



 

 

 

• Verifying the Schematic Symbol. 

• Click on the Schematic Symbols tab in the upper left of the Library Manager. 

• Change the Library drop-down at the top of the dialog to $Downloads. 

• Click on the symbol for the part you downloaded (determining that symbol name 

is described above in Finding the Names of The Symbols in The Component 

bullet at the top of this section). 

• The part will appear on the right if the Preview checkbox is clicked on. 

• To edit the part, click the Edit button. 

• Go to File>Save to keep any changes made. 

  
• Verifying the PCB Symbol. 

• Click on the PCB Symbols tab in the upper left of the Library Manager. 

• Change the Library drop-down at the top of the dialog to $Downloads. 

• Click on the symbol for the part you downloaded (determining that symbol name 

is described above in Finding the Names Of The Symbols In The Component 

bullet at the top of this section). 

• The part will appear on the right if the Preview checkbox is clicked on. 

• To measure features or edit the part, click the Edit button. 

• The Measure tool is located under Tools in the main menu. 

• For through-hole parts, the pad Width dimension must be .014" over the hole size 

to pass annular ring checks. This is best determined from Settings>Styles in the 

Pads tab. 

• Verify all dimensions of the part. 

• The footprint can be printed from File>Print, set the scale to 100. It is good 

practice to put a sample on the printout to verify the footprint. 

• Dimensions and diagrams on the part will not appear on the PCB and do not 

have to be deleted from the part. 

• Go to File>Save to keep any changes made. 

 
 
 
 
 
 
 
 
For questions, contact Layouthelp@AdvancedPCB.com 
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Component Creation and Library Manager                                                                                 
Back to the Menu 

Not finding the part you are looking for 

The most effective search method is using this method: 
1. From the main menu, go to File>Libraries. 
2. Click on the Component Tab. 
3. Use the Find button in the central row of buttons. 

 

 

4. Next to the Name field, Change the drop-down menu from Is Exactly to Contains. 
o It can also be very effective to search by pin number, unless the pin count 

is very small. 
5. If you cannot find the part you are looking for in 5 minutes, you should just create 

it.   
o Almost any part can be created in 5-15 minutes in PCB Artist, especially 

with the PCB footprint wizard.   
o That new part can then be saved into a library you create and is 

organized in a way that best suits your preferences. 
PCB Artist has an online library available.  This may be found: Here 

 
Creating Components 
There are millions of parts in circulation; it is not possible to pre-package a library with all 
the parts in it.  There is a downloadable tutorial available for creating parts.   

• This link will download that PDF tutorial.   
• Procedure for getting maximum benefit from the Part Creation Tutorial: 

1. The tutorial builds a part step-by-step.  Build that part in PCB Artist along with 
the tutorial. 

2. Refer to the overview of the PCB Symbol Wizard and Manual Part Creation in 
this document. 

https://www.advancedpcb.com/getattachment/fe53d6e7-cf6c-4fb4-bfd0-331d5395a0d1/Part-Creation-Tutorial_APCB.pdf


 

 

 

3. Note down any questions you have in the process. 
4. Email the questions to Layouthelp@AdvancedPCB.com when you have 

completed the tutorial. 
 

Overview of the Schematic Symbol Wizard 
1. Schematic Symbol Creation  

a. Click on the Schematic Symbols tab in the upper left of the Library 
Manager.  

b. Click on the New Lib button in the upper right.  This will create a new 
Library for your part.  Always put edited or created symbols of any kind in 
a library you created, or you risk losing them in the future.  

c. Click the Wizard button in the center column.  
i. Click Next on the 1st page 
ii. Choose the Units and make the Precision 4 if you use Inches, 

Precision 3 if you use mm, and 1 if you use mils.  Click Next. 
iii. Choose one of the schematic shape symbols.  In the upper right, 

change the Origin radio button to Pin1.  Click Next 
iv. On the Styles page, leave all at the defaults and click Next. 
v. On the Pins page, distribute the pins on each side of the symbol 

as you wish.  Leave the Distance between Pins, Width across 
Symbol, and Length of Pin Leg all at the defaults.  Click Next. 

vi. On the Finish page, Name the symbol.  Click on the Save Symbol 
to Library checkbox and change the dropdown to the library you 
created above.  Click off the Edit Symbol New checkbox.  Click 
Finish. 

 
Overview of the PCB Symbol Wizard 

1. Look up the data sheet of the part you need to create from the distributor or 
manufacturer. 

a. Warning:  If the data sheet shows a PCB footprint (which is rare), you 
should create that footprint exactly as specified by the manufacturer.   

b. Some types of specified footprints are easier to manually create (see 
below for manual part creation), than to create with the wizard. 

c. Parts with no specified PCB footprint are usually easier to create in 
the PCB Symbol wizard.    

2. Go to the Library Manager, which is on the top icon bar.  It is the fifth icon 
from the left that resembles a book. 

3. Click on the PCB Symbols Tab. 
4. Click the Find button in the middle column.  Search for the exact name you 

wish to call the part you will create.  No two parts in the library can have the 
exact same name.  Confirm the exact name is not used anywhere else. 

• IMPORTANT - All parts you make or edit must be placed in a library 
of your own creation.  They should never be placed in a library that 
came pre-packaged in PCB Artist.  When upgrading PCB Artist, all 
the pre-packaged libraries will be overwritten and new or 
modified parts residing in them.  That directory can be backed up in 
advance of the upgrade, but the best practice to prevent data loss is 
to create your own libraries to store your new parts and parts you 
have modified. 

5. Click the New Lib Button on the upper right.  This will create a new library, 
and you will be asked to name it.   

mailto:layouthelp@4pcb.com


 

 

 

6. Click the Wizard button in the center column of buttons. 
7. In the wizard Start page, click the Next button. 
8. In the Technology page of the wizard: 

a. You can choose to use a Technology file.  Technology files save 
many types of settings from previous parts, such as Styles settings, 
Units settings, etc. 

b. Units:  This can be independently set from the schematic or layout 
units that you will use in your design.  This should be set to the same 
units as the part’s data sheet. 

c. Unit Precision:  This controls how many decimal places are shown 
after the whole number of any displayed or entered numbers.  

i. For example, if the Precision is set to zero and the Units are 
inches, a .250” hole would show as size zero.  

ii. If the Units are set to millimeters and the Precision is set to 1, 
the user can enter a .25 grid to in Settings>Grids but the 
system will change it to .3. 

d. Click the Next button.   
9. On the Type page there are several packages to choose from.  Choose SOIC 

for this example.  Click the Next Tab. 
10. On the Pads page you specify the dimensions of the part from off the 

datasheet of the manufacturer.   
a. A representation of the part is constructed on the right.  It adjusts as 

you change values. 
b. Notice that if you change the number of pads, the symbol changes on 

the right to match. 
c. The gold and gray colored rectangle in the bottom center of the page: 

i. Viewed from looking down upon it. 
ii. The gold is the pcb surface mount land. 
iii. The gray is the actual lead as it will sit on the surface mount 

land. 
iv. The “H” dimension controls the heel, which in PCB Artist is 

defined as the sides and heel. 
v. The “T” dimension controls the toe.  
vi. The “PW” and “PL” dimensions represent the actual size of the 

surface mount. 
d. Click Next to continue. 

11. The Silkscreen Shape page is for specifying the details of the silkscreen.  
Click the Next Page. 

12. The Placement Outline page is for specification of the part outline that will be 
placed on the Document layer.  That layer can serve as an assembly 
drawing.  Click the Next button. 

13. The Finish page is where you save the part and specify its library.  Make 
certain you are saving to a new library of your own creation. 

 
 
 
 
 
 
 
 



 

 

 

Overview of the Component Symbol Wizard 
1. Creating the Component.  This will join the schematic and PCB Parts.  

d. In the Library Manager, click the Component Symbols tab. 
e. Click on the New Lib button in the upper right.  This will create a new 

Library for your part.  
f. Click the Wizard button in the central column.  

i. Click Next on the Start Page. 
ii. Choose Normal Component and click Next. 
iii. Details page: 

1. Component Name will be the name of the symbol in the 
library. 

2. Package is the type of package; you can type one in if you 
do not like the ones listed in the drop-down menu.  These 
names do not have any attributes that impact the part of its 
function. 

3. Default Reference is the name of the reference designator 
that will show on the silkscreen in the PCB layout. 

4. Component Pins is as the name suggests.  In selecting the 
part, it will only show PCB Symbols with this pad count in a 
particular library. 

5. Number of Gates.  For this type of part, just leave it at the 
default 1.  Click next. 

iv. Schematic Symbols page, first choose the library the Schematic 
Symbol was saved to, then select that part on the left.  Make sure 
the Preview button is clicked on.  Click Next. 

v. PCB Symbol page works the same as the Schematic Symbols 
page.  Make sure the Preview button is clicked on.  Click Next. 

vi. Assign Pins page, click the Assign 1 to 1 button.  Click Next. 
vii. Finish Page; choose the Component Symbol library you had 

created above.  Make sure the Edit Symbol Now button is 
checked if you want to assign logic names to the pins, if you do 
not want that you must un-check this checkbox.  Click Finish and 
the Component Symbol Editor will launch. 

2. Manual Component Symbol editing.  
a. The Gates column will be with only one gate, that is as is should be.  
b. The SCH Symbol Name column should be left as is.  
c. The SCH Symbol Terminal Name is where you can enter the logic names 

of the pins of the part.  You do not have to enter them, but if you do not, 
they will not show on your schematic.  On a BGA, it will likely be too 
crowded to display them.  

d. The next three columns are for pin association.  They should have the 
exact same number in each row.  

e. The Net Class Name column should be empty.  
f. Go to File Save.  Exit the part.  

3. Making the logic names show in the schematic. 
a. Select the specific component, right-click and go to Properties.   
b. Click on the Pin Names and Pin Numbers checkboxes to see those 

items.   
c. Click OK to exit and save your change.   
d. The logic names of a pad can be seen in the Status Bar in the lower left 

frame of the application without displaying them in the PCB Design. 



 

 

 

 
Manually create a connector or part (simple) 

1. Look up the data sheet of the part. 
a. Warning:  If the data sheet shows a PCB footprint (which is rare), you 

should adhere to that exact footprint regarding hole sizes and any surface 
mount land patterns.  Thru-hole pads should use a pad that has no less 
than .014” annular ring. 

2. Most Data sheets use relative dimensions to define the part.  We must manually 
convert all of these to absolute dimensions from a point we can easily reference. 

 

 
 
3. Go to the Library Manager, which is on the top icon bar.  It is the fifth icon from 

the left that resembles a book. 
4. Click on the PCB Symbols Tab. 
5. Click the New Lib Button on the upper right.  

a. All parts you make or edit must be placed in a library you have created. 
b. When upgrading PCB Artist, prepackaged libraries will be overwritten 

(unless they are backed up in advance).  To prevent data loss, the best 
practice is to make new libraries. 

6. Click on the New Item button.  This opens an editing screen like the Edit PCB 
screen. 

7. Making your pad and hole sizes. 
a. Go to Settings>Units and set the units to the type used in the part 

drawing.  In this example, use Inches with Precision set to no less than 3. 
b. Go to Settings>Styles. 
c. Click on the Pads Tab. 
d. Making the Component Pads Style: 

i. Click on the Add Style button 
ii. Give the pad a name.  This is its Style Name, which you should 

note down. For this example, call this Pad1. 
iii. If no hole size is suggested, it is recommended that you make the 

hole .010” larger than the pin diameter. Since the diagonal of the 
square is given, we will use that dimension as the diameter. In this 
example, the four outer pins .060”, so the hole size needs to be 
.070”. 



 

 

 

iv. Make the pad (Width) no less than .014” (.36mm) over the hole 
size.  In this example, the hole is .070” and the pad is going to be 
no less than .084”.  

v. Click on OK to add the Style. 
e. Creating the center hole style 

i. Click on the Add Style button 
ii. Give the pad a name.  This is its Style Name, which you should 

note down. For this example, call this Pad2. 
iii. For this example, the pin size is .050”, so the hole size should be 

.060”. 
iv. Make the pad width at least .074” for this pin. 
v. Click OK to add the style.  

f. Adding the four pads. 
i. Go to Add>Pad, but before clicking to add, type the <S> key to 

select the style, (Pad1), then select OK. 
ii. Then, right click and select Add Multiple Items. Since the four 

pads are symmetrically spaced apart, we can input the proper X 
and Y distances from the centers of the pad. For this example, 
they are spaced .200” from center to center per the fabrication 
drawing. 

 

 
 

iii. Place the pads in the design space. Type the <Esc> key to exit 
out of the Add Pad command. You can zoom in or out to adjust for 
a proper view of the pad.  

 

 



 

 

 

 
g. Setting up the grid to add the center pad. 

i. Right click on the lower left pad and select Origins>Set System 
Origin at Item.  

ii. Now, we need to set the grid up so that it will be easy to place the 
center pad in the correct place.   

1. Go to Settings>Grids. 
2. Set up the grid so that it is at 50mil intervals and click OK. 

 
h. Adding the center pad.  

i. Since the grid is set up so that the center pad will be placed 
directly in the center of the four outer pads, go to Add>Pad. 

ii. Before placing, type the <S> key and choose the center pad style 
(Pad2). Then place it in the center of the four pads and type the 
<Esc> key so that you will not continue to add any more pads.  

 
8. Adding silkscreen outline. 

a. Go to Add>Rectangle (or any other shape). Type the <L> key and select 
the top silkscreen layer to create a silkscreen outline for your part. 

9. Save the PCB Symbol to the Library you have created for it and click OK to save 
and exit. 

 

 



 

 

 

Manually create a connector or part (complex) 
There are no connector templates in the PCB wizard.  This is the process to create one.  
There are many other types of parts that are so different in footprint variation that they 
cannot have a common template in the PCB symbol wizard.  These must be created 
manually. 

1. Look up the data sheet of the part. 
a. Warning:  If the data sheet shows a PCB footprint (which is rare), you 

should adhere to that exact footprint regarding hole sizes and any 
surface mount land patterns.  Thru-hole pads should use a pad that 
has no less than .014” annular ring. 

2. Most Data sheets use relative dimensions to define the part.  We must 
manually convert all of these to absolute dimensions from a point we can 
easily reference. 

 
a. Print out the data sheet, it is recommended to blow up the 

dimensioned area.  Use a pencil to make the conversions and note 
these absolute dimensions on the print-out as seen in the example 
below (the notes are in red). 

b. Choose an easily accessible point on the part as the origin from which 
all absolute dimensions will reference.  In the graphic example below, 
the indicated hole will serve as the origin, and all manually converted 
absolute dimensions referencing it are in red. 

c. You must always determine the x and y location of each mounting 
hole and also the lower left component hole of each grid of 
component holes. 

 



 

 

 

3. Go to the Library Manager, which is on the top icon bar.  It is the fifth icon 
from the left that resembles a book. 

4. Click on the PCB Symbols Tab. 
5. Click the New Lib Button on the upper right.   

• All parts you make or edit must be placed in a library you have 
created. 

• When upgrading PCB Artist, prepackaged libraries will be overwritten 
(unless they are backed up in advance).  To prevent data loss, the 
best practice is to make new libraries. 

6. Click on the New Item button.  This opens an editing screen like the Edit PCB 
screen. 

7. Making your pad and hole sizes. 
a. Go to Settings>Units and set the units to the type used in the part 

drawing.  In this example, use Inches with Precision set to no less 
than 3. 

b. Go to Settings>Styles.   
c. Click on the Pads Tab. 
d. Making the Component Pads Style: 

i. Click on the Add Style button 
ii. Give the pad a name.  This is its Style Name, which you 

should note down. For this example, call this CompPad1. 
iii. Make Drill the finished hole size suggested by the 

manufacturers drawing.  In this example .040” 
iv. Make the pad (Width) no less than .014” (.36mm) over the 

hole size.  In this example, the hole is .040” and the pad is 
going to be no less than .054”.  

v. Click on OK to add the Style. 
e. Creating the Mounting Holes Style: 

i. Click on the Add Style button 
ii. Give the mounting hole a name.  This is its Style Name, which 

you should note down. For this example, call this 
MountingHole1. 

iii. Make Drill the finished hole size suggested by the 
manufacturers drawing.  In this example .096” 

iv. Make the pad (Width) the same size as the mounting hole, 
.096” in this example.  The pad exists as a presence on Top 
Copper for other features such as Pour Copper to avoid.  In 
manufacturing, the pad will be removed.  

v. Click off the Plated checkbox. 
vi. Click OK to save and exit the dialog. 
vii. A warning will say that the drill completely removes the pad. 
viii. Click OK to save and exit the Styles dialog 

8. Place the Mounting holes. 
a. Placing the Origin. 

i. Because the datum is a mounting hole, we must place them 
first.  The origin position defaults to the first pad placed. 

ii. Click Add Pad, drag the cursor to the work area, but do not 
add it yet. 

iii. Click the <s> hotkey to choose the Style of pad to add.  
Choose the mounting hole you had made from the list. 

iv. Add the pad. 



 

 

 

v. Change to Select mode by clicking the white cursor arrow far 
right icon on the top icon bar.  The icon looks like a cursor. 

vi. Select the pad, right-click on it, and choose Origins>Set 
System Origin at Item (NOT “At Cursor”) from the right-click 
context menu.   

1. All dimensions displayed or entered in the design are 
now based off the center of this pad. 

b. Placing the second mounting hole. 
i. Click Add Pad. 
ii. The Style will be the same as the last one used, so it’s not 

necessary to change it. 
iii. Place it anywhere. 
iv. Change to Select mode by clicking the far-right icon of the top 

icon bar.  The icon looks like a cursor. 
v. Select the pad that was just placed, right-click over it and go to 

Properties. 
vi. In Properties, Type its destination X and Y axis coordinates in 

the Position fields.  In this example, those coordinates are 
X=1.35, Y=0. 

vii. Click OK.  The mounting hole will move to those target 
coordinates. 

9. Placing the grid of component pads. 
a. Go to Settings>Grids.  Click on the Working Grid Tab. 
b. Change the first textbox of the Step Size section to the X axis 

coordinate of the lowest component pad in the far left.  In this 
example, that is .525” (the true coordinate is -.525”, but the grid 
system does not accept negative numbers, and a negative number is 
not necessary). 

c. Click on the Different Y checkbox.  In that blank type in the Y axis 
coordinate of the lowest component pad in the far left.  In this 
example, it is .150” (the true coordinate is -.150”, but the grid system 
does not accept negative numbers, and a negative number is not 
necessary). 

d. Click OK to accept the changes and exit the Grid dialog. 

 



 

 

 

e. Click on Add Pad.  Drag your cursor to the work area, but do not place 
any pads. 

f. Right Click and choose Add Multiple from the right-click context menu. 
g. The Add Multiple dialog window: 

i. In the Number of Items section, we must set how many pads 
we are adding in the X and Y. 

1. In the X, we are setting 4 component pads (for this 
purpose, ignore the stagger on every other row).  Set 
the X to 4 

2. In the Y we are also using 4 in the Y axis.  Set the Y to 
4. 

3. Many options on this screen that were grayed out are 
now editable. 

ii. The Step Offset Section. 
1. The X is the center-to-center distance between pads in 

the X axis.  In this example, enter .150” in the X. 
2. The Y in this example is .100”.  Ignore the shift offset 

for now.  In this example enter .100” in the Y. 
iii. The Insert Order Section. 

1. In this case, make sure the toggle is set to Insert Row.  
This is because every other row is staggered.  (If 
changed to Insert Column, then every other column 
would be staggered.) 

2. Stagger Pitch is to establish how much the 2nd row is 
staggered from the 1st.  If set to Insert Row, create a 
stagger (or indent) an X axis dimension.  If set to Insert 
Column, it would be a stagger in the Y axis dimension.  
In this case the stagger is -.050” (the negative number 
is allowed and necessary).  The negative number 
means the 2nd row will start further to the left than the 
1st row.  If the drawing showed the second row starting 
to the right, it would be a positive number (.050”).  
Enter -.050”. 

 



 

 

 

iv. Click Ok to save your settings and exit that screen. 
h. Click the <S> hotkey and choose the appropriate Style for this pad.  In 

this example, use CompPad1. 
i. Now move your cursor until it is in the correct position.  Use the Status 

Bar coordinates in the lowest left frame of PCB Artist to ensure you 
are at the correct grid coordinates.  Then click once to add that grid of 
component pads. 

j. Add the second grid of component pads using the same process as 
described above, with these exceptions: 

i. Go to Settings>Grids and change the grid X to .125” and leave 
the y as offset at .15. 

ii. Change the number of items in X from 4 to 8. 

 

  
k. Confirm the Dimensions are correct. 

i. Find each dimensioned pad, right click on it and choose 
Properties from the right-click context menu.  Confirm that the 
coordinates displayed in Properties are correct.  

ii. Use Origins>Set System Origin at Item to change your origin 
to confirm that the part data sheets original relative 
coordinates are correct.   

iii. Warning:  Confirm every relative coordinate on the data 
sheet. 

1. This verifies: 
a. That the conversion to relative coordinates was 

done correctly. 
b. That nothing was incorrectly typed in. 
c. That no assumptions or oversights occurred 

during the entire process. 
2. Be aware that occasionally a manufacturer’s data 

sheet is incorrect, and the numbers do not add up.  At 
this point the part manufacturer would have to be 
contacted for the correct dimensions. 

10. Legend Edits. 
a. Go to Settings>Grids and change your grid to a .050” grid.  Click off 

the Different Y checkbox and click OK to save the changes and exit 
the dialog. 

b. Click on Add Shape Rectangle 
c. Hit the <L> hotkey and change your layer to the Top Silkscreen (if it 

isn’t already on the Top Silkscreen). 
d. Use Add>Shape Rectangle to add the legend outline of the part by 

clicking in the lower left to start the rectangle and double-clicking on 
the upper right corner. 



 

 

 

11. Go to Add>Reference Origin and Click on any open area.  The “+R” is a 
place holder for the part’s reference designator.  The actual reference 
designator text “Conn” would be applied when editing the Component. 

 

12. Adding the Placement Outline.  
a. The Placement Outline is a box, often a bit bigger than the Legend 

outline. 
b. Add it in the same manner as the Legend.   
c. This outline will go on the Document1 layer (or the Document 2 layer 

in some cases) 
d. The Document layers are usable for Assembly Drawing layers, and 

the outline can serve that purpose, or can be used for many other 
purposes. 

13. Changing the Part Datum 
a. Find Pin 1 on the part Data sheet.  In this example, it is the pin in the 

upper left. 
b. Select that corresponding pad on your part, right click on it and 

choose Origins>Set System Origin at Item.  That pad is now the 0,0 
center. 

c. Select the “+S” symbol that is the Symbol Origin.  You may need to 
use the <n> hotkey to cycle through the different objects at that 
location until it is selected. 

d. Right click and choose Properties from the right-click context menu. 
e. Change its Position to 0,0.  The Symbol Origin must always be on Pin 

1.   
i. It is recommended to always put the System Origin on pin 1 so 

that the pads on the PCB Grid.  This makes it much easier to 
route tracks to the pads. 

ii. Some believe that placing the System Origin at the middle of 
the PCB Symbol helps CPL file (component position file) 
generation.  System Origin has no effect on determining the 
center of components.  Placing the System Origin at the center 
will often cause all pads of the component to not be on the 
PCB grid. 

14. Renumber Pins 
a. Pins are automatically numbered as they are added, including 

mounting holes.  When we placed our mounting hole origin for this 
part, it became pin 1.  We must change this. 

i. To View the Pin Names more clearly, go to View>Colors.  
Click on the Other Items tab of the Colors Dialog box in the 
upper left.  Click on the Pin Names Checkbox. 

b. Go to Edit>Renumber Pins. 



 

 

 

c. Click OK in the Renumber Pins dialog box to start numbering pins. 
i. Notice that in the Status Bar on the lower right application 

frame is now in Renumber Pins mode. 
ii. You will also notice in the Status Bar the “Next Number” box 

indicates the number 1.  This is the number that the next pad 
you click on will be changed as well. 

d. Click on pin 1. 
e. Click on each pin, in sequential order, until all the pins are numbered. 
f. Lastly click on each mounting hole, they also must have a pin number. 
g. Hit the <esc> key to exit Renumber Pins mode. 

15. Save the PCB Symbol to the Library you have created for it.   
a. Make certain that you are using a unique name that is not used 

anywhere else in the library.   
b. You must add this new symbol to a Component Symbol to add it to 

any design, regardless of whether it is being added to a schematic or 
a PCB design. 

16. Component Creation 
a. Any part that contains mounting holes cannot be created with the 

Component Symbol wizard. 
b. Use the New Item button in the Library Manager’s Component tab to 

create any components with mounting holes. 
 
Creating Gold Fingers and Edge connectors 
Gold edge connectors must be created as a component, like a connector.  This is a 
three-step process.  First make the schematic symbol, then the PCB Symbol, then join 
the two and associate their pins in creating a Component.  On the instructions below, we 
assuming you’re familiar with Part Creation Tutorial. 

1. Create a Schematic Symbol with all the pins for the top and bottom of the 
connector. 

2. Create the PCB Symbol manually.  As far as creating the PCB symbol is 
concerned, you first must determine the dimensions of the fingers and the pitch 
from center to center.  The basic steps are touched on in the FAQ document 
under the topic “Manually Create a Connector or other part”, here are the 
differences: 

• Instead of making drilled pads, these will be surface mounts.   

• Use the Add>Add SMD tool and use the Add Multiple features to add the 
contact pads, very similarly to how it’s done in the FAQ.   

• Then highlight all of them, Edit>Copy to copy them, press the <L> key to 
change your working to the bottom side, then Edit>Paste to paste the 
second row on the back side.  

• Pay special attention to the Renumber Pads section. The pads are 
numbered by default in the order they are added, so you will likely have to 
change them. 

3.  You will then have to create your component.  The FAQ topic “Overview of the 
Component Wizard” will show you how to do that and how to map the pins.  The 
Part Creation Tutorial also has some information on this. 

 
The following is an explanation of how the gold fingers are defined per the PCB 
Configuration (Settings>PCB Configuration>Board Requirements): 



 

 

 

 



 

 

 

Creating a Circular Part/Circular Placement 

For Circular placement of pads within a component, one will have to take several extra 
steps to set up the component. This will assume that you have gone through the 
component creation tutorial found under Help>Tutorials. 

This footprint will have to be created manually in the library. This example is for a “Tube 
Socket” part, but the concepts found here may be used for any circular parts placement. 

In the Library Manager, on the PCB Symbols tab click “New Item”.  One will be 
presented with a blank screen. Go to Settings>Styles. On the pad styles tab add a style. 
Make it the size of the drill hole indicated by the manufacturer, and for the pad width add 
an additional .014” or .3556mm (or more) for the annular ring. 

 

Set the system origin then center a circle on it. Use Add>Shape>Round for the reference 
line. The symbol origin was also added to the system’s origin. 

 



 

 

 

Add a pad (Add>Pad) or use the add pad icon. Hit the “S” Hotkey to change the style.  

Place the first pad by coordinate. This can be done by right clicking and selecting the 
option, or by hitting the “=” key 

Place the first 2 pads, one directly above 10.5mm on the y and below -10.5mm. Put a 
pad in the center also. 

 

Select the outer pads first and then the center pad. Right click and select Rotate by and 
put in the 36 degree value. 

Add two more pads as above, but rotate these 72 degrees, using the center pad again 
as an anchor (remember to select the center pad last). Rotate in increments of 36 
(36,72,108,144) 

When done it should look like this: 

 

Remove the center pad, and the extra pad on the right. Also, right click on each pad and 
select Properties. Here one may change the pins for pin mapping. 



 

 

 

 

Once finished save the footprint off in your own personal library. 

All components should be created on the top side. One may place a component on the 
bottom side by pressing the “F” hotkey when drawing out their PCB. 

Another possible option would be to create this component with the CAN footprint within 
the PCB Symbols Wizard.  One will be given the option to edit the footprint at the end to 
remove extra pads, renumber pads, and change the silk outlines. 
 
Verifying Component Footprints 
Often when users have created a footprint, they may need to verify it. 
The first step would be to review the data sheet for the footprint. 
 

 
 
The first thing to do is check the pad size. Place the part onto a blank PCB. Turn off the 
soldermask layers (these are clearances for your pads, not actually your copper pads). 
To turn off the soldermask layers go to the interactive bar (F9) and uncheck them on the 
layers tab. Highlight a pad and right click, select properties. The properties of the pad will 
appear: 



 

 

 

 
 
The largest pad is .118 x .236”. The documentation shows this pad should be .24” x .26”. 
The largest pad size is incorrect. 
 
The smaller pads are .06” x .1” in the documentation, and .055” x .08” in the drawing 
(also undersized). 
 

Next, use the measurement tool . This also appears in the menus under 
Tools>Measure.  
 
The smaller pads should appear under the larger pad with a .06” gap between them. 
Note in the picture below the measuring tool is on the Gap Tab: 
 

 
 
The above shows the pads are .102” apart not .06”.  
 



 

 

 

Next lest select the spacing for the two smaller pads. These can be measured center to 
center. It shows in the diagram both pads are .09” from the center, so center to center 
measurement should be .18” apart. These show .136” apart. Note the measurement tab 
is on Distance, which will show center to center spacing. 

 
 
 
 
The final test, once the part is corrected, is to print the part out at 100% size and place a 
sample part on it. It’s a good way to see if there are any glaring issues with the footprint. 
 
Unusual soldermask clearances 
 
This is an explanation of what may be needed if a soldermask clearance needs to be 
manually created due to a unique shape. 
 
Here is an example of a unique soldermask: 
 

 
 
 



 

 

 

This layout is difficult to achieve in the software as the vias will share the soldermask 
clearance of the thermal pad below them. 
 
As shapes only can appear solid with no holes missing, one will have to work their way 
around this. This is a basic example of what one can do. We are going to create a 
clearance out of several clearances to allow the pads to be covered. To do this one will 
have to manipulate the soldermask outlines for the desired effect by double clicking, 
breaking and moving the lines around. At the end one may use the Arc option when right 
clicking on a line. Bear in mind, the central pad and the thermals will have to be added 
AFTER the part has been placed on the board. There is not a way around this as the 
central pad created will have full soldermask relief if part of the actual component.  
 
In this case, start with the thermal pad only appearing on the Top Copper. This will 
remove the soldermask clearance. For the vias use Add>Via. To set the soldermask 
correctly for these vias, one needs go to Settings>PCB Configuration>Layers. Check the 
Cover Vias box. This will work for only vias, not regular pads being used as vias. If done 
correctly this set up will not have any soldermask relief (right now).  In the following 
examples copper is indicated in red, Vias in yellow and soldermask relief in blue gray. 
 

 

 
 
Now go to Add>Shape>closed shape. Carefully trace on the Top soldermask a shape 
that looks like this: 

     The same with just the vias present:      
 



 

 

 

Right click on a straight edge and select Arc. I used 140 for this example arc. 

      Repeated:      
 
Right click on it and select properties. Click the filled box. Copy this outline 5 times. The 
last time rotate it 180 degrees. 
 

 
 
Copy the other side back over 4 more times and manually place the clearance. 
 

 
 



 

 

 

The above is the complete soldermask clearance. 
 
What it looks like with the copper: 
 

 
 
Verify the soldermask relief using the interactive bar: 
 

 
 
 
 
 
Finished hole size 
Always research the manufacture’s part and use what they recommend.   

• If the manufacturer provides no information and all other information sources 
are exhausted, the hole should be made at least .010” over the thickness of 
the lead.  This is intended as a rule of thumb.  The burden of research and 
verification that the rule applies to a particular design scenario is upon the 
designer. 

 
 



 

 

 

Pad size 
The minimum requirement is a pad that is .014” over the hole size.  For a .020” hole, 
make at least .034”.  For vias, the minimum required pad is .01” over the hole size.   
 
Mounting holes 
You can make them in two different ways: 

1. The Quick way: 
a. Use Add pad to place the pads. 
b. Use <Ctrl> to select all the pads to be changed. 
c. Right-click on any one of the pads and select Properties from the 

right-click context menu. 
d. Change the Drill to the required finished hole size. 
e. Change the Width (which is the pad width) to the same size as the 

drill. 
f. Click off the Plated checkbox. 
g. A warning will say the drill removes the pad, click OK. 
h. This method will not give a Style name to these holes and will make it 

difficult to group select all of them by the Style name.  This technically 
puts them into the “Unnamed” Style group with many other shapes 
making them tedious to have to select by group in the future. 

 

2. The Best Practices way: 
a. Go to Settings>Styles. 
b. Click on the Pads tab. 
c. Click the Add Style button. 
d. Enter a Name by which the new style will be referenced. 
e. Enter the Drill Size. 
f. Enter the Width (which refers to the pad width). 
g. Click off the Plated checkbox. 
h. Click the OK button to save and exit. 



 

 

 

i. An error message will say the drill removes the pad, click OK. 
j. Click Add Pad and drag your cursor over the work area, but do not yet 

add the pad. 
k. Click the <S> hotkey (or right-click and choose Change Style). 
l. In the dialog box that appears, choose the name of the style you created. 
m. Add the Pad(s). 
n. The advantage to creating a style is: 

1. You only need to go to Settings>Styles to edit all the holes in the 
group at one time in the future.  

2. You can select and display all items using the Style in the Goto tab of 
the Interaction Bar.   

 
 

Make sure the mounting hole pad width is the same size as the through hole. 
 
Place pads dimensionally 

1. Print out your data sheet for the part. 
2. Data sheets usually have relative dimensions.  We need to manually create 

absolute dimensions to an origin which can be easily referenced on the design.  
Manually convert all dimensions to their absolute dimensions from that origin.  
You can place a pad to serve as the origin and delete it later if necessary (but 
this will require the use of Edit>Renumber Pins to correct). 

3. Right click on the datum and click Origins>Set System Origin at Item.  The 
displayed coordinates and grid will now be snapped to that object. 

4. Go to Settings>Styles of the objects that need to be placed dimensionally. 
5. Click Add Pad, drag the cursor over the work area, and hit the <s> to choose the 

Style to be added.  Place the objects anywhere in the work area. 
6. Select each object, right-click and choose Properties from the right-click context 

menu.  Type in their absolute coordinates.  When you click OK to save your edit 
and exit Properties, the object will move to those coordinates. 

7. When all items are placed, change your origin as necessary to confirm all relative 
and absolute coordinates.   



 

 

 

 
 
Soldermask clearances 
Here is now the soldermask layer works:   

• Thru-hole pads are placed on layer [All] automatically.  This means they have 
pads on all layers when added to or translated into a PCB.  This includes an 
automatically generated soldermask clearance of exactly the needed size. 

• If you use the PCB Footprint wizard, it will automatically place surface mount 
devices on the [Top] layer.  The [Top] layer automatically creates a clearance for 
the surface mount device on the Top Copper layer, the Top Soldermask layer, 
and the Top Solder Paste layers.   

• If you place a surface mount component on a PCB and use Flip to change it to 
the bottom side, all [Top] values automatically become [Bottom] and all other 
relationships to layers are treated accordingly. 

• If you need a soldermask clearance that does not correspond to a specific pad, 
such as a large soldermask clearance over the whole component, use Add 
Shape.  Use the <L> hotkey to change your working layer to the Top 
Soldermask.  Draw the polygon and then select any segment of it, right-click and 
choose Properties from the right-click context menu.  In Properties, click on the 
Filled checkbox.   

o Use the Layers tab of the Interaction Bar to display only the Top Solder 
Mask layer(s) to view the shapes.   

• Be aware that all objects on the soldermask are clearances in the soldermask 
and everything that is black in the soldermask layer will have the green 
soldermask covering.   

• WARNING:  If you create a contact land with copper pour it will NOT have a 
soldermask clearance.  Copper pour is not the correct tool to make contacts with.  
A solder mask clearance would have to be manually created using Add Shape 
Polygon to create the cleared area on the appropriate soldermask layer and then 
go into the polygon’s Properties to click on the Filled checkbox. 

• WARNING:  If you Add Pad and then use Properties to make it a surface mount, 
it will be associated to the [All] layer, where all thru-hole pads live, and will be 
present on every layer.  Surface mounts must be on layer [Top] or [Bottom].  The 
netlist will also believe the surface mounts have an electrical connection to the 
other surface mount counter parts on the other layers, where none exists, and 
will display the rats nests and autoroute accordingly. 



 

 

 

 
Non-Plated Cut outs in a Component Footprint 
If a component requires non plated cut outs within a component footprint, they will need 
to be placed after the component is placed on the board.  For reference one may draw 
the component information out on the silk or documentation layer, but the same 
information will need to be drawn on the Board layer. 
 
Updating Components 
Often a component will need to be changed or updated.  Even if the component is 
updated just by the footprint, it should be updated on the schematic and the PCB file to 
make sure the boards are consistent.  The function to update components is found in 
Tools>Update Components>Browse.  Although the option to update all components is 
available, it is suggested to only update the one component selected through the browse 
list. 
 
Packages 
Package in component generation relates to the type of chipset and shape the 
component part is.  When creating a part, by default the package is “User”. 
The following is a list of a few packages and possible footprints (details and drawings 
are approximate, and are just examples): 

DIP:  Dual Inline Package  SOIC:  Small Outline Integrate Circuit 

 
 

 

 

SOJ:  Small Outline J-lead  SON:  Small Outline No-lead 

  

 

 

QFP:  Quad Flat Pack QFN:  Quad Flat No-leads 



 

 

 

 

  
 

PGA:  Pin Grid Array  BGA:  Ball Grid Array 

 

 
 

 

CAN:    Axial: (through pin resistors, etc) 

 
 

  

SIP:  Single In-line Pin  SOD:  Small Outline Diode 

 
 

 
 

SOT:  Small Outline Transistor Simple Connector 



 

 

 

    

    
 
Extracting components from the .pcb and .sch files 
One can extract the components from a .pcb file and .sch file in the Library Manager.  To 
do so, go to the Library Manager and select a tab.  For the schematic symbol, you will 
need the schematic.  For the PCB symbol one will need the PCB File.  For a complete 
component (PCB And Schematic symbols both) you will need both the schematic and 
PCB file found within the same place. 

1. Start with the Schematic Tab in the Library Manager and create a new library for 
the components that will be extracted.  Next, click on the Add File button.  
Navigate to the schematic file, select it and press OK.  

2. This will extract all the schematic symbols into the newly created library.  Do the 
same for the PCB symbols with the PCB file.  

3. The components tab will also be extracted from the .pcb file.  If the schematic 
and PCB symbols already exist in the libraries, extracting the components will 
then be complete. 

 
Adding a schematic symbol to a PCB only Component 
There is an option to add a schematic symbol to an already PCB only component by 
using the Add menu option in the Component editor.   

• Open the Library Manager (Ctrl +L), and go to the Components tab.   

• Select a PCB only component and click the Edit option. 

• One may select Add>Gate option to add the Schematic symbol.   Locate the gate 
in the library pop-up.  The user will need to make sure the pin mapping is done 
correctly, using the upper table found on the Edit window. 

• Once done, save the component in the library.  

 



 

 

 

 
 

Adding a PCB symbol to a Schematic symbol only Component 
One may add a PCB symbol to an already Schematic only component by using the Add 
menu option in the Component editor.   

• Open Library Manager (Ctrl +L), go to the Components tab.   

• Select a Schematic only component and click the Edit button. 

• One may select Add>Package option to add the symbol.   Select the PCB symbol 
in the library pop up.  The user will need to make sure the pin mapping is done 
correctly, using the upper table found on the Edit window. 

• Once done, save the component in the library.   
 

 
 

Adding Multiple Different Gates 
Users are given the option to have multiple and different gates added to a component.  
This option is different than drawing a gate that has multiple shapes in it for the 
schematic symbol. When gates are added in this way, each gate can be moved to 
different areas of a schematic, and even to another schematic page. One may add a 

separate different gate to a component use the Add>Gate icon  while editing the 
component.  This is the same icon one would press to add a schematic symbol to a PCB 
only component.  Further modifications may be made in the Component Editor by going 
to Edit>Gates.  This will then allow one to remove a specific symbol or add other 
symbols. 
 
Adding Multiple Different Footprint Options for a Component.  
One may add variations of footprints to the same component.  To do this one must be in 
the component editor.   

Select the Add Package symbol on the far-left Design Menu.  
This can be done several times to the same component. 



 

 

 

When adding this component through the Add Component tab on the Interaction Bar, 
one will be presented with a drop down below the parts list.  This drop down will only be 
available when a component has multiple packages available to it.  
Packages may be added or removed from a component in the Component Editor by 
going to Edit>Packages. 
 
Library Export to .palib 
Once a component has been created, a user is able to export it to a .palib file.  This file 
will retain all the information regarding the component and can be installed onto another 
computer with PCB Artist.  The file acts the same as the downloaded .palib files from the 
online library.  One can “Drag and Drop” the files onto the PCB Artist Icon to install them 
or use the Add File button in the Library Manager. 
 
The option to output a .palib file appears on the Components Tab of the Library manager 
as the Export button. 

 



 

 

 

Schematic Creation                                                                                                                      
Back to the Menu 

 
Multipage schematic 

1. Go to File>New and choose a Project. 
2. Then go to File>New and choose a new Schematic.  Check the box at the bottom 

of the dialog to Add to Open Project.  

 
 
3. Page frames for the schematic can be found in the Schema library. 
4. Off page references between schematic pages are made simply by the nets 

having the same name set in Settings>Nets. 
a. This does not apply to generically named nets (the “N0000” named nets).  

Generic nets are local to the page they are on only. 
b. In Settings Nets, if a GND net is created and it exists on another page, 

they will connect whether a connection or off page reference is drawn. 
c. In the Implied Connection instructions (the topic directly below) also apply 

to off page references between Project sheets.  However, the hanging 
connection will turn red indicating it is unconnected.  It will connect due to 
the net associations, despite appearing unconnected.  To make this 
clearer and to remove the hanging connection highlight, use the To and 
From symbols of the Schema library.  Those symbols do not have any 
special attributes; the net name itself is all that is needed to make the 
connection. 

5. Splitting component gates is best covered in the Help section of PCB Artist.   Go 
to Help>Contents and type into the search blank the “project gates”.  Click on the 
topic “Splitting Components Across Schematic Designs” for complete details. 

 
Implied connections 

1. Draw a connection off a pin.  Drag it a few grid points and double-click to 
terminate it there.  The connection will turn red to indicate an un-terminated 
connection. 

2. Select the connection, right-click and choose Change Net from the right-click 
context menu.  Choose the net that you want it joined to. 

3. The color of the connection should change to black to indicate the connection is 
no longer un-terminated. 

4. Right click on the connection again and choose Display Net Name to verify the 
process was successful at a glance. 



 

 

 

 
 
Power and ground symbols 
These are in the Schema component library. 
 
Changing values of components 
Use either a window selection or the <Ctrl> button (in the same way you can use it to 
select specific files in Windows Explorer) to select all the specific components of that 
type to have the value changed.  Then right click on any one of them and choose 
Properties.  In the Properties window, click the Values tab.  Select the value in the list 
and use the Edit button to change it.  All the components will now have the new value. 
 
Symbol doesn’t show on Add Component list 
Schematic and PCB Symbols cannot be added to a board directly.  They must be first 
joined into a Component Symbol.  Only Component Symbols can be added to a PCB or 
Schematic. 
 
Fetch Component 
In the PCB and Schematic context menu one may fetch a component to the current 
cursor position by right clicking in a blank area and selecting Fetch component.  The 
hotkey for this is Shift+F.   

 
 
This will list any components that are in the Component bin and found on the drawing.  
By selecting it from the list, the component will instantly appear at the cursor. 

 



 

 

 

 
 
Displaying pin logic names 
This is done at the component level. 

1. Go to the Library Manager 
2. Click on the Component tab. 
3. Go to the correct library and select the part.  Click the Edit button 
4. Enter the logic name in the Terminal Name column (third column from the left).  

On the schematic part, the new names will show at the N# locations. 

 

5. Save and exit. 
6. Open the schematic and then go to Tools>Update Component. 
7. If the logic names are not displayed, right click on the component and choose 

Properties.  Click on the check box for Pin Names. 



 

 

 

8. If the Pin Names do not show, go to View>Colors.  Click on the Other Items tab 
and click on the Pin Names checkbox if it is checked off.  Click OK to save your 
changes and exit the Colors dialog box.  

 
Auto Rename Components 
Under Tools>Auto Rename Components, is an option to allow one to Rename the 
components across a schematic automatically.  Options are as follows:   
 

 
 
Forward Changes from schematic to PCB 
Often when changes are needed on existing board files it is best to do them to the 
schematic first, then forward those changes to the pcb drawing.  This allows the 
schematic and pcb drawing to remain consistent, and for the designer to run a 
consistency check to make sure both designs are still the same.  To forward changes 
from the schematic go to Tools>SchematicPCB>Forward Design changes.   This will 
create a report that will state all the changes that have been made to the pcb file.  
Forwarding Design changes will unroute any nets that no longer match the schematic, 



 

 

 

remove parts that are no longer in the design, add parts, and change net names. 

 

 

Spice Simulation  
Spice Simulation is covered in the Help>Context Help menu under Spice. 
Schematic Busses 
In a schematic, one may add a bus through the Add>Bus menu. 
One can create a closed bus by adding nets through the properties of the bus.   
Adding connections to a bus without assigning nets to it will make an open bus, and any 
net may be assigned to it.   
 
 
Schematic to DXF Printing 
PCB Artist can output the schematic as a DXF format print.  The option appears on the 
top menu, Output>DXF.  

 

 

 



 

 

 

The New PCB Wizard                                                                                                                   
Back to the Menu  

 
Change the board size 
You can delete it and completely redraw it in the PCB, but it must be created and 
finalized before placing an order. 
 
Unit Precision 
Unit Precision is found in Settings>Units.  Precision is how many decimal places any 
displayed coordinates are rounded up to.  If you have the Units set to Inches and the 
precision is set to zero, then the displayed size of a .250” hole will be 0”.  Set Unit 
Precision appropriately for the units you have selected.  Recommended Precision for 
Inches is Precision 4, for Millimeters is Precision 3 and for Mils is Precision 1. 
 
Board Template 
When you create PCB Designs, you can save it as a template.  That will save the board 
with all its settings, components, board outline, and even tracks and copper pours.  You 
can then use that saved template to start a new design with all those features built in for 
future designs.  It can be used to save as little as unit settings or as much as whole 
designs.  Be aware that if you save a template for a design, the entire design is saved, 
not just select features.   
 
Layers 
It is easy to add layers after the New PCB Wizard, but when eliminating layers, you can 
only eliminate the last inner layers.  If you create a 10 layer board and find out that you 
only need 6, when you go to change the layer count you can only eliminate layers 9, 8, 
7, and 6 (the Bottom Copper will become the new layer 6).  This also changes the 
possible plane layers to 2, 3, 5, and 6, which may be a major conflict of some of those 
layers are already routed signal layers.  It is recommended to start out with a small 
number of layers and then once the layout has progressed to a point where the need for 
more layers is unavoidable, add the layers then from Settings>PCB Configuration. 
 
Split and mixed inner planes 
The plane layers are intended as pure planes.  They should never be edited under any 
circumstance, even to draw a single track.  On the layers page, leave them as signal 
layers and then when editing the PCB, use Pour Copper to draw split and mixed planes. 
 
Minimum track width and space 
The default is 10 mils, you can change it in the design, but you will have to go to 
Settings>PCB Wizard when you are in the PCB design and change this value on the 
Board Parameters page.  The system will not allow you to submit the order if this 
number is not correct.  It will prompt you if this value is different. 
 
V-score and Tab rout 
Basic Design Requirement orders cannot have a v-score or tab route, due to 
overwhelming request of customers seeking the lowest possible cost.  This includes 
orders with arrays.  To get those options, select Expanded Design Requirement on the 
Design Requirement Page of this wizard. 
 
 



 

 

 

 
Special Requirements text box  
It’s intended for any requirements that do not already have an option in the wizard and 
also for extra details of items you can select.  Some Examples: 
If the board is a flex design and requires a thinner final thickness not listed on the board 
thickness drop-down menu of the Board Parameters page (but was verified as possible 
for your design, through PCB Artist Technical Support), this would be the place to 
specify it.  Special billing or shipping information can be noted here as well as any 
special instructions.  The board has countersinks, use this space to specify the counter 
sinks and to differentiate which holes are the countersinks.  You can return to this page 
from Settings>PCB Configuration once you are in the design. 
 
Part number and revision 
We must have a way to reference the part for future orders.  The software requires both 
of Entries to be filled out before order placement. 
 
Arrays 
See the Array section here. 
 
Change options after New PCB Wizard 
Some options run in the PCB Wizard can be changed long after PCB Creation.  This can 
be done from the main menu click on Settings>PCB Configuration to change some 
values.   

 
• Warning:  Reducing the number of layers in this manner can eliminate nets.  

If layers must be eliminated, go to Output>Net Completion Report to get a report 
of the nets that are now incomplete.  Then from the main menu, go to 
Tools>Optimize Nets to make the un-routed net connections appear.  They can 
be manually or auto routed from that point.  After they are routed, it would be 
wise to go to Output>Net Completion again to confirm nothing was lost. 

 
 

 



 

 

 

PCB Design Edit                                                                                                                            
Back to the Menu 

 
View Power plane layers 
Go to View>Powerplane>Show to view pure plane layers.  Mixed and Split planes are 
considered signal layers (one uses pour copper to make the planes), so those layers are 
viewed normally as any signal layer. 
 
Selecting a particular item 
Use the “N” hotkey to cycle through objects at that location until the object you want is 
selected. 
 
Remove net highlight 
This can be done by going to View>Highlight Net>Remove Highlight.  If the highlight is 
from selecting a net on the Interactive bar, go back to the net selection area (Interactive 
Bar>Go to Tab>Nets in the drop down).  Right click under the list, or in an unselectable 
area and select “Remove Highlight”.  The other option is View>Goto>Remove Highlight. 
 
Cross Probe Function 
In PCB Artist version 1.5 a Cross Probe function has been introduced.  This allows users 
to select nets and pins on the schematic to highlight the same nets on the PCB file.  
Users are also able to highlight the nets, tracks or pads on a PCB Design to highlight the 
same on the schematic.   

This function may be accessed under Edit>Cross Probe, or by the icon .   
 
Displaying layers 
Bring up the Interaction Bar with <F9> and Click on the Layers tab at the very bottom of 
the Interaction Bar.  Right-click over the list of layers and choose the All Layers Off 
option.  Then click on just the layers you want to view. 

 



 

 

 

 
Properties of an object display size as zero 
Go to Settings>Units and change the Unit Precision to a larger number.  Precision is 
how many decimal places any displayed coordinates are rounded up to.  If you have the 
Units set to Inches and the precision is set to zero, then the displayed size of a .250” 
hole will be 0”.  Set Unit Precision appropriately for the units you have selected.  
Recommended Precision for Inches is Precision 4, for Millimeters is Precision 4 and for 
Mils is Precision 1. 
 
Select all the segments of a trace at once 
Push and hold down the <shift> key, then select the trace.  You can also select multiple 
whole traces by pushing and holding down the <ctrl> and <shift> keys. 
 
Pad and Feature Colors 
On the default color settings: 

• Grey pads are present on all layers.   
o In Properties, they show as being on layer [All].   
o Surface mounts should not be grey.  If they are, the component needs to 

be edited to change them from layer [All] to layer [Top] (NOT to be 
confused with layer Top Copper!  An object on layer [Top] automatically 
has a soldermask clearance and solderpaste clearance generated.  It will 
also flip all those to the [Bottom] layer if the Flip option is used on the 
component. 

• Dark Red pads (using the default color settings) are on Layer [Top] IF they are a 
slightly darker red than the Top Copper traces.  If they are the same shade of red 
as the traces, then they are not on the [Top] layer, they are on Top Copper and 
will have no soldermask or solderpaste clearance.  They must be changed to 
layer [Top] in Properties (see previous bullet point).  

• Dark Teal pads (using the default color settings) are on layer [Bottom].  They are 
slightly darker than the traces on the Bottom Copper Layer.  Have all the other 
properties of objects on layer [Top], described above. 

• Yellow pads are vias created by the application when using the autorouter, 
moving a track segment to another layer, or other processes where the 
application places the hole automatically.  They are present on layer [All] but are 
not associated with a component.  Most commonly these are vias. 

 
The following information relates to what layers the feature will appear on, function, or 
error.  
 

PCB Color Coding:  

Gray:  Appears on all layers, and the soldermask layers.  In the 
properties drop down it will show as [All]. 

 



 

 

 

Red:  Appears on the top copper only, and not the soldermask.  If 
this is a pad, in the properties drop down it will show as [Top 
Copper]. 

  

Dark Red:  Appears on the top copper and the top soldermask.  In 
the Properties drop down, it will show as [Top]. 

 
 

Cyan/Teal:  Appears on the bottom layer with no soldermask 
clearance.  If a pad, this will show as [Bottom Copper] in the 
properties drop down. 

  

Dark Cyan/Teal:  Bottom copper with soldermask clearance.  In 
the properties drop down, this will show as [Bottom]. 

 
 

Yellow Pads:  These represent vias.  Vias appear on all layers. 

 

 

Bright Green:  Board layer.  The board layer is the outline/route of 
the board. 

 
 

Dark Green:  Documentation 1 layer 

 

 

Dark Blue:  Documentation 2 layer 

 

 

Slate Blue:  Top Silk Screen 

 

 



 

 

 

Purple:  Bottom Silk Screen 

 

 

Orange/Coral:  Top soldermask layer 

 

 

Light Gray:  Bottom Soldermask layer 

 

 

Function colors:  

Thin yellow Lines:  Thin yellow lines indicate disconnected nets 
that may need to be drawn.  These are commonly known as “Rats 
Nests”. 

 

 

Dark Blue Tracks/Pads:  This may indicate that a net has been 
highlighted. 

 

White:  This is an actively selected object. 

 

Track with a Pink Inner Line:  This indicates a disconnected track 

 



 

 

 

Green Highlight:  Non net highlight.  One may turn off the 
highlight by going to View>Goto>Remove Highlight 

 

  

Schematic Color coding:    

Orange:  Selected Connection 

 

Cyan:  Net Selected Connection Highlight 

 

Black: Un-highlighted Connection/Schematic Symbol 

 

Pink:  This indicates an incomplete connection. 

 

Dark Cyan/Teal:  Pin number 

 

Olive:  Pin name, sometimes will show as a N# as a designator 

 



 

 

 

Blue:  Text, Symbol Text, and Value Position 

 

Drawing on a different layer 
Here is one way to do it. 

1. Click on Add Track 
2. Right-click and choose Track Layer OR hit the <L> hot key. 
3. Click the box that says Apply to All Segments if want the whole track on the layer 

you are switching to. 
4. Select the layer you wish to draw on in the dialog box that appears.  It will 

automatically default to a layer other than the one you are on, so just hit return to 
accept it if you are on a double-sided board and you will be on the Bottom Side 
automatically. 

 
Draw at odd angles 

1. Click on the icon of the type of drawing you wish to make (such as Add Track, 
Add Board Polygon, Add Shape Polygon, Add Track, Add Copper Pour Area 
Polygon, etc.). 

2. Click to add the drawing and move your cursor to the work area.  
3. Before starting the drawing, right click to open the context menu.   
4. Select Segment Mode>Free 
5. Now lines can be added at any angle.  
6. If moving shape segments, use the Free Rubber-banding option from the right-

click context menu to allow the attached segments to take any angle.  
 
Moving component to the other side of the board 
Select the component, right-click on it and choose Flip.  This may also be done by 
selecting the component and using the “F” hotkey.  It’s best not to have track 
connections to the component before placing it on the opposing side. 
 
Corners with radius or chamfer 
If you double click on 90-degree rout corner, it will take the corner into Miter or Fillet 
mode.  In the Status bar in the lower left frame of the application, the phrase Edit Miter 
(or Fillet) Mode will appear.  When you drag the cursor, it will increase the Fillet or 
Chamfer at each grid point.  Go to Settings>Grids in advance of the edit to set the grid to 
the correct value.  Right click while in miter (or fillet) mode to toggle between miter and 
fillet. 
 
Make draws with 45-degree angles  

1. Click on the icon of the type of draw you wish to make (such as Add Board 
Polygon, Add Shape Polygon, Add Track, Add Copper Pour Polygon, etc.). 

2. Click to add the start of the shape. 
3. Right Click to open the Context Menu while you are still in draw mode.   
4. Select Segment Mode>Miter.   
5. You can now draw at angles and the system will automatically put all junctions at 

45 degrees. 



 

 

 

6. It may help to change your draw mode to Free.  See the question above 
regarding drawing at odd angles. 

 
How to remove track segments 
Often a track must be partially redrawn if clicking and dragging the track is not sufficient.  
To remove one segment of a track: 

1. Select the track and right click on it. 
2. Select Net>Unroute Track Segments 

The highlighted track segment will disappear.  PCB Artist will consider both sides of the 
track gap and all included pads and copper features to be still part of the same net.  This 
will be indicated by a yellow line by default, commonly known as a “Rats Nest”. 
 
Change a pad (or track) size universally 
Here is one of several ways to do this: 

1. First determine the pad style used from the properties box.   
2. Go to Settings>Styles.   
3. The Styles window will open, click on the Pads tab.   
4. The names of each pad style are listed.  A new style can be created, or an 

existing style can be edited from this window.   
5. Be careful to be sure that the change will not affect more pads than you intended 

to affect. 

• Various combinations of selections and added styles can be used to 
accomplish different goals in selectively changing styles. 

• The Interaction Bar’s Goto tab can be used as a powerful tool when set to 
styles.  Right clicking on the name of the style and choose Select All Find 
Items is another way to select all the items and to see them all selected 
before editing them either with Properties or through Settings>Styles as 
described above. 

 
Allowing Duplicate Tracks 
Initially PCB Artist is set up to not allow multiple tracks to connect the same two points 
on a board.  This can be bypassed by going to Settings>Preference>Interaction tab and 
putting a Check in the box beside “Allow Duplicate Tracks”. 

 



 

 

 

 
Mounting holes 
That answer is above in the Component Creation section found here:  Mounting holes  
 
Adding a Coil or Spiral 
One may add an evening generated spiral using the Add>Spiral Function inside of PCB 
Artist.  This can be done as a shape or track with the following options: 

 
 
Add Dimensions 
In version 3.1 of PCB Artist, users can add vertical, horizontal, straight dimension to their 
drawings for reference.  This is done through the Add>Dimension menu option, or by 
using the Icons on the PCB design menu: 
 



 

 

 

Plated Slots 
 
Here are the procedures for making plated slots, and slots for components. 
 

1. Non-plated Slots may be made using the Add Board polygon. Any Board outline 
within the main board outline will be treated as a hole.  The minimum width of 
any slot is .031” non plated, .026” plated on a regular Expanded board. 

 
 

2. Plated Slots for PCB and PCB Symbols. 

• This is a new feature for version 1.1.2 or later.  If you have PCB Artist 1.1, go 
to Help>Check for Updates to download that patch.  If you version is older 
than 1.1, download the latest version from https://www.advancedpcb.com/en-

us/tools/pcb-artist-software/   
1. Go to Settings>PCB Configuration in the design (or if you are making a 

component symbol, just make sure this step is done before adding the 
component or the plated slot will not appear in the component). 

a. On the first page of that wizard, set the design to Expanded Service. 
b. On the Board Parameters page, click on the checkbox for Plated 

Slots. 
c. Go to the Production Page of the wizard and click the Finish button. 

2. Go to Settings>Styles 
a. Create an Oval pad style that is the exact dimensions of the finished 

plated slot.   

• The Smallest width possible .026” for an Expanded board, 
.02” for a Premium Expanded. 

• Make the Drill Hole size zero. 

• Give it a name, such as Slot 
b. Create an Oval pad style that will be the pad of the plated slot. 

• The width and length of the pad should be .014” over the slot 
dimensions at the minimum. (For example, a .030” x.150” 
slot must have a pad no smaller than .044”x.164”.) 

• Slot pads Slots should always be on layer [All], which they 
will be on by default when built in this method. 

• Make the Drill zero. 

• Keep the Plated box checked. 

• Give the style a name, such as SlotLand. 
 

3. Click Add Pad.  Move your cursor to the work area but not add anything yet. 
4. Click the <s> hotkey and choose the style of the slot created in step a above 

(not the slot pad style created in step b). 
5. Place the pad at its correct final dimensional location. 

c. Warning – once the slot is changed from a pad to a draw, using copy 
and paste or move features will no longer be grabbing the object from 
center, but from the center point of the lines in the oval.   

• This means the pad must be placed in the required position 
before conversion to a slot polygon. 

• This also means that multiple slots placed with copy and 
paste should be completed at this point and not after 
conversion to the slot polygon. 

6. Select the oval pad. 

https://www.advancedpcb.com/en-us/tools/pcb-artist-software/
https://www.advancedpcb.com/en-us/tools/pcb-artist-software/


 

 

 

7. Right click on the Selected Oval Pad and choose Change Shape Type.  In 
the drop-down menu, choose Shape. 

• Warning – Do not change origins or grids from this step until the slot 
land is added. 

 

 
 

8. Click Add Pad.  Move your cursor to the work area but not add anything yet. 
9. Click the <s> hotkey and choose the style of the slot pad created in step 1-b 

above (not the slot style created in step a). 
10. Add the pad right exactly over the center of the slot. 
11. The Plated slot will be viewable on layer Plated Slot of a PCB Symbol and the 

Plated Slot layer in PCB Artist. 
a.  Warning – If a component with a plated slot is placed before the 

option has been activated in Settings>PCB Config>Board 
Parameters, the plated slots information that will show on the plated 
slots layer will be lost! 

 

 
 
Reminder: Make sure the Plated slot layer is activated in PCB Configuration before 
placing any components with plated slots in them. 
 



 

 

 

Creating a complex board Shape 
The first approach is if you already have a complex board shape created in .dxf format.  
Then all that is needed is to import the .dxf onto the Board layer.  See “How to Import a 
.Dxf” for instructions. 
 
If this is not an option, then starting with a general board shape, then modifying it will be 
your best option.  Some of the most complex board outlines may only be 5 or 6 
continuous lines: 

  

The above outline started with a large rectangle Shape from Add>Board>Rectangle.  By 
double clicking the board outline to modify segment (also an option available with right 
clicking and selecting modify segment), we were able to pull and drag our outline to a 
closer shape of the desired board.   To deactivate the edit, double click again.  To reset 
the edit while editing, one may hit escape and all changed features in the current edit will 
snap back to the previous shape.  It’s good practice to have the grid (and Grid Snap) set 
to a desirable distance for snapping to.  The Grid snap and Grid functions are available 
in Settings>Grids (or Ctrl+G).  Segments may be changed into Arcs by right clicking on a 
line segment and selecting Arc.  There will be various options there for different Arc 
degrees, and the ability to also Flip the Arc. 



 

 

 

Complex Round Outlines. 
 
Outlines are required to be closed. To create a circle that has notches missing takes 
planning. 
 
There are two approaches to this.  First one can use a .dxf of the complex shape from 
another software program, then import it as outlined in this FAQ here.  The other option 
would be to draw the complex shape within PCB Artist. This follows some directions 
found in this FAQ here.  
 
First as a guideline draw the outline shape on a documentation layer. This will be 
reference for the outline that will be built out of a polygon option single closed line. 
It depends on how the board has been set up. Adding an extra notch into a board outline 
with an extra shape can be misinterpreted by CAM, and the notch may not be created.  
 
This example starts with a Polygon shape: 
 

 
 
Then double click on the corners and drag them inward to create a miter.  
 

 
 



 

 

 

Right click on specific segments and select Arc. For the above I selected a generic 45 
degrees. When an arc appears backwards, right click on it again, select Arc, and select 
Flip Arc.  
 

 
 
This is approximate above and may take practice and tweaking to get a perfect shape. 
By using the Arc function under the free option, one can heavily modify a segment with 
an Arc. 
 

 
 
With straight lines, one may double click and break the line a drag the segment of the 
outline around. The outlines are easily deformed. 
 
 
 
 
 
 
 
 
 
 



 

 

 

Creating a Quarter Circle/ Curved board shape 
It is possible to create a circle segment inside the software, but it takes a bit of pre-work 
to get it to run correctly. 
 
First, set the grid snap to the thickness of the ring you are making (for this example we 
are making the grid and grid snap .25”.    (settings>grids) 
 
Go to Add>Shape.  Add a circle.  To create a circle from the center, right click while 
making a circle and select “Define from Center”. 
To change the layer the circle is being made, hit the “L” hotkey.  We will use the 
documentation layer for this.  Right click again, and select diameter, set the diameter to 
16. 
Do this a second time with a circle that is .5” less (15.5”) 
 
Then create an 8” by 8” board outline.  Delete the old outline or modify it.  To add an 
outline, go to Add>board. 
 
At this point is should look something like this: 

 

 
 
Double click on the upper right corner.  This will activate the “miter” function. Drag in the 
corner until the line reaches the inner circle: 

 



 

 

 

 
 
Do the same for the lower side: 

 

 



 

 

 

 
Right click on the mitered corner and select ARC.  Select the free option.  At this point 
one can drag the arc to match the outline on the documentation layer: 

 

 
 
Without the documentation layer: 

 



 

 

 

 
 
Keep in mind the above set up above is considered an 8” x 8” board.   
After the board has been laid out, one can select all objects with a frame select (with all 
layers activated) and rotate the board 45 degrees.  This would give the lowest profile: 

 

 
 
The above boards would be roughly 3.2” x 6.2” on a Panel. 
 



 

 

 

Non-Plated Cut outs  
Non plated cut outs are created on the board layer with the board outline.  One may go 
to Add>Board and select a shape.  The smallest non plated cut out dimension available 
is .031” on a Basic or Normal Expanded spec board.  For a premium Expanded spec 
board, the smallest non plate cut out dimension is .02”.     
 
 
Editing the soldermask 
That answer is above in the Component Creation section. 

• Be aware that all objects on the soldermask are clearances in the soldermask 
and everything that is black in the soldermask will have the green soldermask 
film covering.   

 
Via pads 
Make the via pad style 010” larger than the drill size.  So, for a .018” via hole, make the 
pad style width .028”.  Make certain that you are using the Via style in Settings>Styles or 
the Design Rule Checks will not know they are intended as vias and will flag them as 
annular ring errors. 
 
Blind and Buried Vias in PCB Artist. 
PCB Artist currently does not easily facilitate Blind and Buried vias. It outputs only one 
drill file. Drill holes appear through the board completely, and the pads associated with 
them will also appear on all layers normally. Even if the drill hole appears on a few layers 
rather than through the board, the pads often appear still on all layers.  
 
However, with notes and the use of a document layer, one may illustrate what drill holes 
appear on what layers. 
 
An Example would be: 

 
 
Adding personal logos and symbols to the Silk Screen or Copper layer 
To add personal logos into PCB Artist, one option is creating the logo in a font editor as 
a new Font.  There are many font editors available online.  Once the logo has been 
created in the editor and connected to a particular keyboard key, save the file as a True 
Type Font with a distinct name.   Install the font onto your system but keep it handy as it 
will need to be sent to Advance Circuits to allow processing of your PCB Files.  To place 
the logo into PCB Artist, one will place it as a text using the newly created font with the 
logo.  Be sure to send PCB Artist the ‘true type font file’.  Make sure the true type font’s 
name is very specific to avoid possibly overwriting the fonts in our database and the 
possibility of your own personal font being overwritten.   
 



 

 

 

The next option would be to import the image as a DXF file.  There are many Raster to 
Vector image converters available online if the Logo is in Bitmap format.  Otherwise, one 
may draw the logo entirely in Vector format, save it as a DXF file and import it. 
 
Directions for DXF import are found here. 
 
Long delay when moving components on the PCB  
The software is also capable of performing dynamic optimization during component 
move. When moving a component, right-click and select the Place option from the 
context menu. Then move the component again and right-click and choose Dynamic 
Optimize. This will remain a default choice for all parts moved on all future designs, until 
deactivated.   To deactivate it, one may do the same option as above and uncheck 
Dynamic Optimize. 
 
Creating a new Net Class 
The most common net classes in PCB Artist are signal, power and ground.  These 
classes reflect not only the track types and widths but will reflect the type of vias added 
the connections.  Net classes may be used to control the defaults for track widths.  To 
create a new net class, one may go to the Settings> Net Classes and click the “Add” 
button. 
In the Net Class pop up, there will be options to set the minimum and maximum widths 
of the tracks for this class, and options on how the vias will be set up.  Once created the 
new net class can be assigned to a net, and the net will reflect the properties of that new 
class type.  More one Net Classes will be found in Help>Context Help, under Net 
Classes. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

 

 

 
Custom Colors for Nets and Net Classes 
Options for adjusting custom colors for nets or net classes may be set in the color’s 

menu  (hotkey: C). This will allow users to display any net or Net class with a 
specific color indicator (often a colored centerline highlight). 
 

 
 

 



 

 

 

Disconnecting Combined Nets 
 
If two different nets are combined on the pcb file, the user will receive an error while 
connecting. 
 

 
 
This will assign the two nets the same net name, combining them.   Once this has been 
done, it can be difficult to separate these nets and all features between them into two 
separate nets again.   
 
The first and easiest option is only available to users who started with a schematic in 
PCB Artist and converted it to PCB.  The option to forward design changes from the 
schematic will fix any netlist changes, intentional or not.  If tracks have been created with 
the incorrect net name, it is possible the changes will remove tracks but correct the net 
connections.  This is why it is suggested one should always make changes to the 
schematic first and forward changes.  The option to forward design changes appears at 
Tools>SchematicPCB>Forward Design Changes. 
 

 
 
An ECO from an OrCAD Netlist would do the same thing, if the board had initially been 
started from a netlist. 
 
If a user did not start with a schematic, they will have several tasks to separate objects 
that are now on the same net. 
 
First, one must unroute any tracks and copper pours that are connecting to the pads that 
are not on the correct net.  For tracks right click on the track and select Net>Unroute 



 

 

 

Track Path.  For copper pours, right click on the pour and select Unpour copper.  One 
will be given an option when repouring the copper the change the net the pour appears 
on.   
 
Once disconnected, the pads can then be removed from their incorrect net.  Right click 
on an unconnected pad and select Remove from Net. 
 

 
 
Do this for every pad that will be in the separate net.  Proceed now to right click then on 
the unconnected pads again and select Add to Net. 
 

 
 
Add the pads to the correct net.  Connection “Rats nests” will begin to appear on the 
board that should state the correct net.   
 
Because the pads are now on a different net, the routes generated between them will 
also now be on that different net.  
 



 

 

 

Pour Copper area 
1. Draw the bounding box polygon Using Add>Copper Pour Area. 

• You can draw right over the rout and the poured copper it will clip itself back 
from the rout by the exact amount required (which is set in 
Settings>Spacings).   

• The copper pour will clip itself back from all objects in the area that are not on 
the same net automatically (the spacing used is set in Settings>Spacings). 

• In Settings>Spacings, the Shapes row governs the distance the copper is 
clipped back from the copper pour.  The entire Shapes row must always be 
set to no less than .010”. 

2. Click on the Selection Icon to exit draw mode (from the top icon bar, the last icon 
on the right that looks like your cursor). 

3. Click on any one segment of the bounding box you just added. 
4. Right-click and choose Pour Copper from the right-click context menu. 
5. In the dialog box, choose the net it should be on.  Leave that text field blank to 

have the copper pour unconnected from a net. 
6. Click on the Thermal Pads checkbox to automatically add thermal pad 

connections. 
7. Click on the checkbox to remove Isolated Areas at the bottom of that dialog 

window.  Isolated areas will cause rats nests to show those areas as 
unconnected.  Isolated areas will behave as an antenna on the finished board. 
Another option is to use the Highlight checkbox and connect those isolated 
islands with vias to their proper net.  

8. IMPORTANT - The copper pour is applied once to the area it fills.  If changes are 
made after the copper pour (such adding vias, mounting holes, or moving tracks) 
the copper pour will NOT adjust to this new change.  To have the copper pour 
adjust to those changes, simply select the bounding box of the copper our, right 
click and click Pour Copper again.  The Pour Copper dialog box will appear with 
the exact same settings of the previous pour.  Click OK and the pour will be 
adjusted considering the changes made to the area. 

9. IMPORTANT – The copper pour bounding box is not actually a copper object on 
the board, it will not intersect traces or end up in the actual board.  Do not delete 
the bounding box. 

 
Filling copper pour area 
The edit is not yet complete.  Here is how to complete it: 

1. Select any line or arc of the copper pour boundary that you have drawn on the 
copper pour area and right click. 

2. Select properties from the right click menu. 
3. Select the Pour Copper Option 
4. In the next window, select the nets the copper pour will be connected to. 
5. IMPORTANT – once the net is selected, several checkbox options in the window 

become active.  To have thermal connections, the checkbox for Thermal Pads 
MUST be checked in this dialog box. 

 
Copper pour outline box 
The bounding box of the copper pour remains after the copper pour and does appear to 
intersect all traces it crosses.  However, it is not really present and is gone when the 
data is output.  WARNING:  Do not delete the copper pour’s bounding box in case you 
need to re-pour the copper again at a later stage. 
 



 

 

 

Adding items in an existing copper pour 
Select one segment of the bounding box, right-click and pour copper again.  It will re-
examine the connected tracks, holes, routes, etc and re-pour to clear back from them.  
Some notes on this: 

• All previous settings of the previous copper pour will be preserved in the dialog 
box.  So, if those do not need to be changed, just click the OK button to re-pour. 

• New isolated areas may be created by these new edits.  If the Remove Isolated 
Areas check box is checked, these new isolated areas will be removed 
automatically. 

• If you DO NOT re-pour the copper, all those new edits will cause shorts to each 
of those individual nets. 

 
Copper pour around the rout edge 
You can draw the bounding box right over the rout edge and the copper pour will 
automatically clip itself back from the rout to the exact amount necessary. 
 
Thermal connections on plane layers 
In the New PCB Wizard, either no net names were assigned to the planes, or they were 
not spelled the same as the net name (proper case is required as well).   

1. To fix this, go to Settings>PCB Configuration in the PCB file and go to the Layers 
screen.   

2. Use the drop-down menus for assigning the planes to the correct nets to ensure 
that nothing is misspelled or has a different case.   

3. Go to View>Powerplane>Show and view each plane to confirm they now have 
thermal connections. 

 
Improved Thermal Connection Options 
Pad Properties dialog has more control over thermal connections on power planes and 
copper pours. 
Copper pour areas can now override this thermal information. 
Pour Dialog now shows what thermal parameters will be used when pouring a selected 
area. 

1. Copper pour areas in previous designs will be converted to use the equivalent 
new rules. 

2. If a thermal pad has a track on it on the area layer it will now be a valid 
replacement for a thermal spoke. 

3. More options for pads Thermal connections are available on all pads and vias 
through the pad’s properties (a right click option). 

This was available on vias and pads within a footprint but is now also available on 
component pads and free pads in a PCB design. 
 
See PCB Artist help pages for more details. 
 
Mixed and split planes 
On outer layers, just use Pour Copper.  On inners, DO NOT make the intended inner 
layers plane layers, keep them as signal layers.  This can be modified while in the 
design from Settings>PCB Configuration on the Layers page of that wizard.  You can 
then create split and mixed planes using Pour Copper just as it would be done on the 
outers.  Never try to draw on a true plane layer, not even a single trace. 
 



 

 

 

PCB Artist Import/Export 
Currently, PCB Artist may import .dxf files for mechanical functions (like outlines and 
references) and OrCAD EDIF format netlists in place of using a schematic.  PCB Artist 
can export .dxf format and allow printing to .pdf format (See Create a .pdf File).  One will 
be able to export all layers but the copper circuit, in .dxf format.  Gerber files are 
generated by request of the customer on boards that have been ordered and processed 
by the Advanced PCB CAM department. 
 
How to import a DXF format file 
One may import a dxf format file into PCB Artist, using the File>Import function.  A pop 
up will give options for import. 

 

1. This will control the scale.  Often when a dxf is imported and the software does 
not show the scale may be far off. 

2. Double clicking here will show a drop down for what layer the information will 
appear.  The options of shape affect how the information will appear in PCB 
Artist.  It is not recommended to import tracks and pads from DXF to any copper 
layer.   It’s best to use the import DXF function for mechanical reasons such as 
board outlines.   To import an outline the Import as will need to be change to 
‘Board”. 

3. It is not recommended importing text.  Text information and fonts do not carry 
over well from DXF, though the option is still there.  If one was to double click 
under “Import This Layer”, they will have an option to change the import from yes 
to no.    

 



 

 

 

Import OrCAD EDIF Netlists 
Instead of using a schematic generated in PCB Artist.  There is an option to use an 
OrCAD EDIF format netlist instead.  The option to do this is through File>Import.  Before 
doing this one must have all the components already built into PCB Artist.  One must 
also be aware of all the component names found within PCB Artist and the OrCAD 
drawing.  When importing the netlist into a fresh PCB Drawing, the designer will need to 
“Edit Map”.   This pop up will initially be all blank values.  These values are manually 
input to create an OrCAD.map file that PCB Artist will use as reference to match the 
netlist in parts and net connections.  More about Importing OrCAD EDIF netlist may be 
found in Help>Context Help under OrCAD Import. 
 
ECO From Netlist 
To update any changes made to an OrCAD EDIF netlist into PCB Artist one must use 
the ECO From Netlist function.  This is available in File>ECO From Netlist and requires 
the updated OrCAD EDIF netlist.  Like Importing an OrCAD EDIF netlist, if any new parts 
have been added, the parts will also need to be created in PCB Artist, and the 
OrCAD.map file will need to be updated.  More about ECO from Netlist may be found in 
Help>Context Help under ECO from Netlist. 
 
Importing From Eagle 
Native Eagle Schematic (.sch) and PCB (.brd) XML format files can be loaded into PCB 
Artist by either using a drag and drop from the Browser onto the PCB Artist product or by 
using Open from the File menu.  They can also be used in the Add File option within the 
Library Manager. 
Native Eagle Library (.lbr) XML files can be read directly into the libraries using the Add 
File mechanism in the Library Manager. 
This does not include downloaded single parts, as they are scripts to build the part in the 
Eagle software.  Once the part is built and saved into an Eagle library, the library file can 
be imported into PCB Artist. 
 
Alternatively, PCB Artist can import PCB designs, schematic designs, component, pcb 
symbol, and schematic symbol libraries from Eagle versions 4.01 to 6.x. This requires 
having the Eagle software on hand as the file formats will be run through the ULP 
function.  
 
See PCB Artist Eagle Import help page for more detail. 
 
 



 

 

 

The Auto Router                                                                                                                           
Back to the Menu  

 
Auto route with fine pitch components 
There are a few different factors that constrain the autorouter with specific design rules.  
The key to successfully auto routing tighter pitched parts is in reducing the various rules 
the autorouter must obey: 

1. Power and Ground tracks:  Failing to route is often due to the trace width size 
being too large, especially power and ground tracks.  The default power and 
ground sizes are quite large and can perhaps be much smaller, depending on 
the power requirements of the board.   

A. The track size used by the autorouter is determined by the Net Class 
assigned to a net from Settings>Nets.  Power Class and Ground 
Class will be routed with the Power Nom track style and Signal Class 
nets (the default class to any net) are routed with the Signal Nom 
track style.  

B. To change the tracks sizes used, go to Settings>Styles from the main 
menu. Click on the Tracks Tab.  

C. From there click the Tracks tab.   
D. Click on the Power Nom track style.  The default size is 50 mils, which 

will not be able to connect to a .5mm pitch SMD. 
E. The trace width can be changed there for the entire board including 

traces not yet added to the board.   
F. IMPORTANT:  Please be sure to properly calculate trace widths that 

will accommodate the power requirements of the PCB.  This link will 
take you to the AdvancedPCB.com trace width calculator.  If the track 
size is made too small for the board’s power requirements, the track 
may become a fuse. 

G. The autorouter will always use the Power Nom track style to draw the 
power traces unless the Minimum Width checkbox on the Autorouter 
checkbox is checked.  In that case it uses Power Min.  All other track 
styles are ignored by the autorouter. 

H. Style settings can be saved (from a blank PCB file) from File>Save As 
Template if the sizes changed will frequently be used in other designs.  
(It is best to save templates from blank designs, so as not to 
accidentally save other features into the template, such as the board 
outline). 

2. Signal Traces:   
A. To change the traces sizes used, go to Settings>Styles from the main 

menu.  
B. From there click the Tracks tab.   
C. Click on the Signal Nom trace style. 

o Track width can be set as small as 7 mil and be usable with Basic 
Design Requirement. 

o With Expanded Design Requirement, the traces can be as small 
as 5 mil. 

o If a signal track width is changed from the default for either Design 
Requirement type, go to Settings>PCB Configuration.  In the 

https://www.advancedpcb.com/en-us/tools/trace-width-calculator/


 

 

 

Board Parameters page of that wizard, change the Min Track 
Width/Gap to match the new smallest track on your design. 

D. The trace width can be changed there for the entire board including 
traces not yet added to the board.   

E. The autorouter uses the Signal Nom style from Settings>Styles in the 
Tracks tab to draw all signal tracks.  If the Minimum Width checkbox is 
checked in the Autorouter dialog, it will instead use the Signal Min 
track style. 

F. From there click the Tracks tab.   
G. Style settings may be saved (from a blank PCB file) from File>Save 

As Template if the sizes changed will frequently be used in other 
designs. 

3. Another factor in autorouting is the spacing requirements that the autorouter 
is constrained to follow. 

A. If you go to Settings>Spacings, change the pad to track spacing. 
o One may set the spacing to as low as 7 mils with Basic Design 

Requirement. 
o One may set the spacing to as low as 5 mils with Expanded 

Design Requirement. 
o One may set the spacing to as low as 3 mils with a Premium 

Expanded, this is still marked as an Expanded in PCB 
Configuration. 

o If spacing is changed from the default, for either Design 
Requirement type, go to Settings>PCB Configuration.  In the 
Board Parameters page of that wizard, change the Min Track 
Width/Gap to match the new smallest gap on your design (unless 
you already changed if for the track width, and it is the same 
number). 

B. You can change whole rows or the entire grid by changing one cell, 
then clicking out of it, then right clicking over the cell you changed and 
choosing Apply to Row or one of the other options. 

1. You can set the spacing to as low as 5 mils with 
Expanded Design Requirement. 

2. If you Apply to All, you need to change the Board row 
back to 20 and apply it to the whole row.  The minimum 
allowable is 10 mils for a tab route or rectangular rout 
and 15 mil for v-scored designs. 

C. Autorouter Grid: 
1. In the Autorouter Dialog, a change to the Track Grid 

Size can free the autorouter to find new ways to 
connect. 

2. The grid should be set to a derivative of primary grid.  
(For example, a 25 mil grid will not rout to a .5mm part.  
A 12.5 mil or 6.25 mil grid will allow the autorouter the 
freedom to do its job.) 

D. Change Via Styles: 
1. Got to Settings>Styles in the Pads tab. 
2. Change the Via style to as low as .015” hole (with .025” 

pad) for Basic Design Requirement, as low as .008” 
(with .018” pad) for Expanded Design Requirement. 



 

 

 

3. If using Expanded Design Requirement and using a via 
smaller than .015 you must go to Settings>PCB 
Configuration and on the Board Parameters page of 
that wizard change the Minimum Hole drop-down to 
.010” (if you are using a pad smaller than .015” but 
larger or equal to .010”) or .008” if using a size smaller 
than .010”. 

 
Keep out area 
Keep out areas are created through the Add>Copper Pour Area menu option.  After the 
Copper pour area outline is created, right click on the outline and go to properties.  In the 
properties check the “keep out box”.  The keep out area will stop any copper pour from 
crossing into the keep out area.  The keep out also will work on power plane layers (if 
the keep out is drawn on said layer).  This does not show however in the View>power 
plane option view. 
 

 

Track Routing Areas 

Under Add>Track Routing Area.  Track routing areas are outlines that can be used to 
dictate to the software’s autorouter where the tracks and/or vias are to appear.  After 
placing a Track Routing area outline, right click on the outline and select properties.  In 
the properties dialog are options to allow or hinder tracks and vias within that enclosed 
area.  Track routing areas may be set to all layers, or a specific layer within its 
properties. 



 

 

 

Design Rule Checks                                                                                                                      
Back to the Menu 

 
Consistency check 
Go to Tools>Schematic>PCB use Consistency Check to verify the design when 
compared to your schematic.  This will output a report to review any inconsistencies 
between your Schematic and PCB files.  Both files will need to be named the same other 
than extensions and be placed in the same folder to have PCB Artist recognize the files 
being connected.  
 
Reviewing design rule check errors 
Here are some effective ways: 

1. Reviewing a small number of errors: 
A. Select the error message itself. 
B. Use the <n> hotkey to cycle between objects at that location until you have 

the error message selected. 
C. Right-click and choose Properties from the context menu. 
D. There should be a short message giving more information about the error. 

2. Reviewing many errors: 
A. Bring up the Interaction Bar <F9>. 
B. At the bottom of the Interaction Bar, click on the Goto tab. 
C. At the top of the Interaction bar, change the drop-down menu to Error. 
D. This will organize the errors by type and by layer.  Click on the individual 

coordinate list to zoom to that specific error. 
 

Deleting my design rule checks 
Go to Tools>Design Rule Check.  In the Design Rule Check window, click the Delete 
Errors button. 
 

 
 



 

 

 

Design Rule Check errors  

• General Types of Errors: 
o Some design rule errors are per design and cannot be eliminated.  The 

application is simply looking to bring something questionable to your 
attention.   

o Some errors are not un-manufacturable but violate previously set design 
rules.  For example, a design may have a 9 mil spacing error when the 
spacing is set to 10.  The instance can either be edited to a 10 mil space 
or the Settings>Spacings screen can be edited to allow 9 mil spacing for 
that type of error. 

o Some errors are un-manufacturable or would produce a definite violation 
of IPC specifications. 

• The DRC Spacing checks are run according to how Settings>Spacings is set.  
The grayed-out values cannot be changed.  Other values can be changed but 
may affect the pricing of the order. 

 

o All Spacings Design Rule Checks measure the distance from copper to 
copper except for Board spacing and drill spacing. 

▪ It is important to remember that Text and Shapes are on a copper 
layer are going to be copper and will have all the electrical 
properties of a trace or a copper pour.  

▪ Basic Design Requirement orders cannot have a track width or 
space below 7 mils.  Expanded Design Requirement orders 
cannot have a track width or space below 5 mils.   

▪ Spacing or Track width changes require the user to go to 
Settings>PCB Configuration and change the Minimum Track 
Width/Gap settings for the design on the Board Parameter page of 
that wizard.  The application will not allow the order until that 
information is updated. 

▪ The Shapes row governs the distance the copper is clipped back 
from the copper pour.  The entire Shapes row must always be set 
to .010” at the minimum. 

▪ Board spacing is for the distance between the board rout line to 
copper features. 



 

 

 

• Board to copper spacings should all be set at .020” as the 
default in Settings>Spacings. 

• For a routed or tab routed part, the settings could be set to 
.015” at the minimum 

• For the scored part, the minimum allowable spacing from 
copper is .020” or the designer risks exposed copper. 

▪ Drill spacing is to discover if drill holes are overlapping.  This can 
happen when another hole is placed inside a much bigger hole by 
accident and cannot be easily viewable. 

▪ Most often this is seen when a via is accidentally placed inside 
another pad.   

• Click within the pad where you see the error and press 
<N> to cycle through objects present at the point the 
cursor was clicked on.   

• If the via is not totally within the hole, the yellow pad of the 
via may be visible. 

o Net Design Rules check for incomplete nets and Dangling Traces.   
▪ Intentionally dangling tracks will produce an error message that 

will have to be ignored.  Simply note the number of errors so when 
the order is submitted, you can see if the number of errors has 
increased, indicating a new problem that must be investigated 
before ordering. 

• Add a Track to fix the error, if the connection is confirmed 
to be needed. 

• Use Tools>Optimize Nets (or the hotkey <Ctrl+D>) to have 
the software reconsider the netlist.  Sometimes it will 
discover the connection to the net exists in a different path 
than it was expected, elsewhere in the board.   

• If there was no schematic created, there is no way to verify 
the integrity of the design.  A mistaken connection in the 
design can only be manually confirmed (if that). 

• Overlapping copper pour areas can cause this.  The 
system is arranged so that overlapping polygons should 
never be necessary. 

• Isolated areas of a pour copper can cause this error.  It is 
always best to re-pour the pour copper and click on the 
Remove Islands option.  Isolated islands of copper behave 
as antennas. 

• Add Shape objects and filled polygons should only be used 
in areas too small for an effective copper pour.  It is 
preferred to use copper pour wherever possible.  

• It is recommended to always ensure that the schematic is 
diligently preserved as the point of all changes (using 
Tools>PCB>Schematic>Consistency check to forward 
differences from the schematic to the PCB), to avoid the 
most serious of these types of errors, even on the simplest 
board. 

o Manufacturing Design Rules cover many different areas of board design. 
▪ Minimum Line Width checks for tracks, draws and text using a 

smaller line .005” 
▪ Minimum annular ring check for: 



 

 

 

• .007” annular ring for component pads, minimum.  That 
translates to .014” over the hole size. 

• .005” annular ring for via pads, minimum.  That translates 
into .010” over the hole size. 

• Annular Ring Errors on mounting holes – The Plating 
checkbox in Properties has been left on.  If it is clicked off, 
the errors will not continue to show. 

▪ Minimum Drill checks for holes smaller than .008”. 
▪ Text outside board test is to flag text that is outside of the PCB 

and may be an indication of an unplaced component. 
▪ Mirrored text check is to ensure that all bottom side text is wrong-

reading.  Right-reading text on the bottom side will be wrong 
reading after manufacture of the part. 

▪ Minimum solder paste test should be turned off and ignored.  
Solder stencil services vendors should have their own DFM tests 
that should perform for their customer depending on many factors 
that are unknowable. 

• If there is doubt about the correct way to proceed, email your .pcb file and a 
brief description of your situation to Layouthelp@AdvancedPCB.com. 

mailto:layouthelp@4pcb.com


 

 

 

Arrays                                                                                                                                            
Back to the Menu 

 
What is an array? 
An array is putting multiple pieces of the same part number into frame to make small 
boards more manufacturable for fabrication and to reduce assembly costs for small 
boards.  To configure your design to be in an array, go to Settings>PCB Configuration 
and go to the Production Page of that wizard.  Click on the Array Checkbox in the middle 
of the page to open the array options for editing.  These are the various aspects of 
arrays: 

1. The array size must be large enough to encompass all the individual pieces, the 
spacing between those parts, and the border material that holds them together. 

2. The Borders are used for assembly operations to clamp onto securely without 
overlapping onto the board and interfering with assembly.   

3. Tooling holes are also used for assembly operations to pin to.  This is a more 
secure and precise way to hole onto the board than clamping to the borders 
alone. 

4. Fiducials are used as optical targets for automated assembly.  They are used to 
determine precise board alignment. 

5. Scoring is a “v” grove cut into the top and bottom surfaces of an array 
configuration of multiple PCB’s or a PCB with removable rails or frame. The cut 
depth is set such that the material left is the lesser of .018” or 1/3 of the finished 
thickness.  When this process is used the printed circuit boards are typically set 
side by side and end to end with no gap between the edges.  This results in the 
v-grove cutting into the area of the boards, so a .020” clearance between the 
edge of the boards and any conductors is required. 

 

a. When placing an order that requires scoring, please indicate this 
requirement by setting going to Settings>PCB Configuration.   

b. On the first page of that wizard, make the board Expanded Design 
Requirement.   

c. On the Board Parameters page, click on the V-Score checkbox on the 
right.   

6. Tab Routing for Arrays uses the router bit that cuts the board from the production 
panel to cut slots between the individual images, leaving behind small “tabs” of 
unrouted material to keep the array border and individual connected as one.  

a. When placing an order that requires scoring, please indicate this 
requirement by setting going to Settings>PCB Configuration.   

b. On the first page of that wizard, make the board Expanded Design 
Requirement.   

c. On the Board Parameters page, click on the Tab Rout checkbox on the 
right.   



 

 

 

 
An example of Tab-routing:    

 

Making an array 
 
 
Go to Settings>PCB Configuration.  Go to the Production Page of that wizard.  Click on 
the Array Checkbox in the middle of the page. 
 
From here there are two options available for your array set up.  The first is an array 
matrix.  This allows a user to simply state the number boards across and up the array 
will contain.  This then calculates the size of the array, based on the number of x and Y 
boards, but also the type of separation (tab-routing or scoring) of the boards.  Checking 
the box for rails and inputting a value there will also increase the size of the arrayed 
board set up. 

 
 



 

 

 

The other option allows for direct values to be input.  This is shown below on how to set 
this up. 
 
 

1. The optimum array size for efficient panel usage and lowest possible 
production cost is 10.8” x 7.8”.  The goal is to come as close to that array size 
as possible without going over.   

2. Here is an example of a PCB that is 3.5” x 2.2 to set up in a tab routed array: 

 

• To Determine the Array Width for PCB Artist, simply add up the x-axis 
dimensions.  For this board, the array width must be no less than 11.5”.  
Simply add up .4” + 3.5” + .1” + 3.5” + .1” + 3.5” + .4”.   

• The formula for the Array Width is the same, but for the Y axis 
dimensions.  This array width can be no less than 5.3”.  That is .4” + 2.2” 
+ .1” + 2.2” + .4”. 

• Borders to use: 
o The .4” border around the board is the minimum recommended for 

by assembly companies.  .5” is often preferred by assemblers. 
o A .2” border is the minimum manufacturable and cannot be 

changed, other than to increase it.  Assembly will be very difficult 
as only .1” will remain of material.  Tooling holes and fiducials 
cannot be added to this size.  

o To Add Tooling Holes and/or Fiducials to the array, you must have 
a minimum of .4” border per side to the array. 

• Warning:  PCB Artist currently allows a minimum of a .1” minimum 
border to accommodate scored arrays and will allow an order of a tab rout 
with a .1” border.  However, this is not possible to produce and will cause 
the board to go on hold pending customer authorization to increase to a 
.25” border (.2” at the minimum) and approval of any associated changes 
to the cost of the order. 

3. Here is an example of a 3.5” x 2.2” board in a v-scored array: 



 

 

 

 

• The array width on this example can be no less than 11.3”.  That is .4” 
+ 3.5” + 3.5” + 3.5” + .4”. 

• The array height on this example can be no less than 5.2”.  That is .4” 
+ 2.2” + 2.2” + .4”. 

• There is no space between scored parts. 

• The .1” border is the minimum allowed cannot be changed, other than 
to make it larger. 

4. Using the PCB Artist Array Dialog: 

• This example is using the tab route. 

• Note that the Array Width and Array Height have the word “mils” at the 
end of each field, indicating this board is set to mils, and the units 
entered must be in mils, as seen in entering 11.5” as 11500. 

• Array Width is 11.5” (or 11,500 mils) as calculated above.  

• Array Height is 5.3” (or 5,300 mils) as calculated above. 

• Array up is the total number of parts in the array.  In this case 6. 

• Note that the Quantity ordered is 18 parts.  18 individual parts which is 
3 arrays.   

o The Quantity is for the total number of part numbers, NOT the 
number of arrays.  Arrays are never counted, only the 
individual parts which are contained in the arrays. 

o The Quantity MUST be a multiple of the number of boards in 
the array.  It would give an error if I made the quantity 17 or 
19.  However, it would accept 6, 12, 18, 24, etc. 



 

 

 

 

• IMPORTANT – Basic Design Requirement orders are heavily discounted and 
do not include v-scoring or tab routing.  To get v-scoring or tab routing of an 
array, you must go to Settings>PCB Configuration and set the board to 
Expanded Design Requirement.  Then go to the Board Parameters page of 
that wizard and click on the checkbox for either v-score or tab routing (or 
both). 

 
Copy and paste arrays 
It is possible but not recommended. 

• The schematic will now not be able to verify the design 

• The silkscreen reference designators auto-number, meaning that R1 on one part 
will not be R23 on the second part pasted into the array and r41 on the next part 
pasted in.  This will reflect on the BOM, but basically very problematic in 
production assembly. 

• It is possible that in selecting the part across several layers that something may 
be missed and not copied, a schematic comparison will now be unable to catch. 



 

 

 

Order Process Questions                                                                                                              
Back to the Menu 

 
Placing an order  
This link takes you to instructions to the ordering a Basic Design Requirement order.   
This link leads to instructions to place an Expanded Design Requirement order. 
 
Directions for ordering a Student Special board may be found here: Student Specials 
 
Student orders follow the same specs as 33 and 66 specials.  You may order less than 4 
boards on a student order. 
 
33/66 Specials and Barebones Boards in PCB Artist: 
Ordering direction links are found here:  33/66 special ordering 
 
Because of the nature of  promotion codes the pricing for them will appear on the web 
ordering page after you’ve uploaded the files. 
 
$33 and $66 specials with multiple circuits (multi-part boards) are subjective to a one 
time per order 50$ fee due to set up.  This multipart drawing is set up by the customer 
only, not by Advanced PCB CAM (they will not array it for you in this case).  If this is a 
case, the customer will need to approve the “step and repeat” charge by noting it in 
Settings>PCB Configuration>Additional Requirements, in the Special Requirements box.  
$33, $66, and barebones specials do not have internal routing available, either for cut 
outs, scoring, or Tab-route.   
 
Promotion Codes 
The location of a promotion code being applied to one’s order will appear differently in 
the software, depending on the spec of the board. 
 
Basic spec boards will only have Barebones, 33 Special, 66 Special, and Student 
Special promotions available to them.  These are placed here: 
 

 
Student specials will have other steps to take to ensure the correct promotion will 
activate.  Be sure to review their respective directions (Links are in this Order Processing 
section).   
 

https://www.advancedpcb.com/getattachment/db151938-48d2-4cd2-9b09-9d9ff593000e/Order-Process-for-Standard-PCBs-Using-PCB-Artist_APCB.pdf
https://www.advancedpcb.com/getattachment/dff156c8-5080-4671-93c2-f64b32d276dc/Order-Process-for-Expanded-Designs-Using-PCB-Artist_APCB.pdf
https://www.advancedpcb.com/getattachment/51bafee6-96e6-451b-8c8b-4a0f5978564e/Student-Order-Process-Using-PCB-Artist_APCB.pdf
https://www.advancedpcb.com/getattachment/b0525da0-d186-439d-9737-7a1f0ecdaf3c/33-Specials-and-66-Specials_APCB.pdf


 

 

 

Other promotion codes are placed when ordering Expanded Spec boards through PCB 
Artist.  The option will appear on step “3 of 5” of the ordering process, just after 
uploading files. 
 

 
 
If the user wishes to have the promotion added to a Standard spec board, they will have 
to contact a sales representative to have the board quoted Standard spec. 
 
 
FreeDFM 
PCB Artist does not interact with the Advanced PCB FreeDFM Service.  Go to the Order 
Processing section for how to submit your board order.  The Design Rule Check Section 
covers how to view any possible errors with the design that may reflect on the 
manufacturability of the board. 
 
Errors when ordering 
The submit order process automatically runs the Design Rule Checks as part of Submit 
Order to prevent the possibility of not running them before ordering and to catch 
accidental edits that the customer may not have been aware of.   

• If the Design Rule Checks have not been run, it is critical to check them before 
submitting the order.  

• If the checks have been run and the number of errors is verified as per design, 
click to ignore the errors and continue the order process. 

 
Other Errors when ordering: 

• Missing Revision or File Name or Number 
 
In Settings>PCB Configuration on the Production section there are two values 
that will need to be filled out.  The Board Part Number and Revision are required 
to order.  Once done, click finish and submit the board again. 
 

   



 

 

 

 
 

• Items on an Automatic Generated Power Plane. 
 
Power planes (an option within PCB Configuration) are drawn in negative.  Any 
feature added to that layer will remove copper when the boards are produced.  
To view a power plane, go here. 
If a feature needs to be added to the layer, then the layer cannot be an 
automatically generated power plane.  The option will need to be turned off in 
PCB Configuration.  After the features are added, a copper pour may be used on 
the same net as the original power plane.  

 

The .fab file 
The .fab file is a copy of the .pcb file you were working in when you hit the Place Order 
or Get Quote button in the Submit Order process.  It also serves as a “frozen” version of 
the exact file that was ordered.  If your order has issues and you need to send an edited 
file, do your edit in the .pcb file and email the edited .pcb file to us.  The .fab file will not 
be up to date and should only be used when ordering online. 
 
Missing Bottom Silkscreen on a Order 
By default, PCB Artist will not order a bottom silk layer.  This must be activated by 
checkbox in Settings>PCB Configuration>Layers Section.  If the bottom silk option is not 
checked then it will not output, nor be ordered. 
 
Where do I get a quote? 
Where one gets a quote through PCB Artist will depend on the type of board that is 
being ordered.  A basic spec board will have the pricing without shipping or tax in 
Settings>PCB Configuration, on the lower left.  Basic spec boards have a discount for 
them as they are ordered online and are considered a “Hands Off” board.  The full price 



 

 

 

will be available when ordering the board, after uploading the files, and selecting 
shipping options.    
 
Expanded spec boards use the custom spec pricing matrix found online.  To get a quote 
on an expanded spec board, one may go to Output>Submit Order.  Because it is an 
expanded spec board, the option “Get Quote” will be available, but not the Place Order 
option.  Make sure that you have no web browser open.  If you have an online account, 
list the e-mail and password, then click the “Get Quote” button.   If you do not have an 
online account yet with Advanced PCB, then please go here to sign up for one before 
trying to order or get a quote:  https://www.my4pcb.com/Net35/Registration.aspx 
 
ITAR Required Boards 
If International Traffic in Arms Regulations (ITAR) is required on an order, one can note 
it in Settings>PCB Configuration>Additional Requirements section in the Special 
Requirements box.  If ordering through a sales representative, one will need to state to 
sales this is an ITAR board.  During the online order process, you will be asked if ITAR is 
required, in order to complete the processing.   

 
 "International Traffic in Arms Regulations" (ITAR) govern the export of weapons and 
weapons-related technology from the United States.  If your board design data is ITAR-
controlled, please inform us of that when you place your order.  For detailed information 
on ITAR, go to https://www.pmddtc.state.gov/ddtc_public/ddtc_public. 

https://www.my4pcb.com/Net35/Registration.aspx
https://www.pmddtc.state.gov/ddtc_public/ddtc_public


 

 

 

Installation                                                                                                                                   
Back to the Menu 

 
OCX control error 
This is a known issue with some revisions of a Windows file.  The fix depends on your 
operating system.  It is worth checking the date and version of the MSFLXGRD.OCX file 
on your system. There are several different varieties of this OCX file in the field, some of 
them quite different in size and date but showing the same version number.  
 

• Windows 7 and Vista 64: 
1. Right click on Start/Accessories/Command Prompt and select Run as 

Administrator. 
2. Type:        CD C:\Windows\Syswow64 <enter> 
3. Type:        regsvr32 msflxgrd.ocx <enter> 
4. Type:        exit <enter> 
5. Right click on the PCB Artist program icon and select Run as 

Administrator. 
6. From the PCB Artist main menu, go to File>Libraries 
7. Go to the Components Tab, select any component from the left-hand list, 

and click the Edit button from the central list of buttons. 
8. Exit without saving and Close the PCB Artist program. 
9. Restart the PCB Artist normally. 

• The key point here is that the "Run as Administrator" option is only 
available from a menu or shortcut, so you need to launch the 
command prompt itself in this mode by finding it on the Start 
menu. 

 
Permissions accessing a file during installation 

This is a very old Windows XP issue that has come up many times over the years.   

❖ WARNING:  Advanced PCB recommends seeking the aid of or retaining the 
services of an experienced IT specialist to deal with this Windows issue.  
Customers performing this editing do so at their own risk.  It is possible to cause 
irreparable harm to the computer and lose all files on the computer by performing 
any edits to the registry. 

❖ Before Editing: 
1. Backup – This is the process for backing up the registry prior to editing it. 

A. Go to Run and type:  Regedt32 <enter> 
B. Click on File>Export 
C. Save the file to a directory and make a note of its location. 

2. Restore - If the computer needs to be restored to its previous settings 
before the edit: 

A. Run Regedt32 as was done in step a, above. 
B. Click on File>Import 
C. Locate the file from Step c above. 

3. If the computer will not boot up: 
A. Press F8 while it is trying to boot. 
B. Choose the option to restore the last known good configuration. 

❖ The Edit: 
1. Run regedt32.exe (It has to be regedt32 NOT regedit).  



 

 

 

2. Select the window HKEY_LOCAL_MACHINE ON LOCAL MACHINE. 
3. Select the SOFTWARE key.  
4. Click SECURITY (or PERMISSIONS) from the menu bar (under the "Edit" 

menu). 
5. Click PERMISSIONS.  
6. From the Security section, highlight USERS.  
7. Check the option FULL CONTROL. 
8. Click APPLY.  
9. Click the ADVANCED button.  
10. Highlight USERS from the Permission Entries section.  
11. Click VIEW/EDIT.  
12. From the permissions section, uncheck the DELETE option from the 

Allow column.  
13. Click OK.  
14. Click APPLY before continuing to the next step.  
15. Check the option RESET PERMISSIONS ON ALL CHILD OBJECTS 

AND ENABLE PROPAGATION OF INHERITABLE PERMISSIONS. 
16. Click APPLY again. 
17. Click YES at the security dialog warning box.  
18. Click OK to the message about registry editor not being able to set 

permissions on some keys.  
19. Click OK back at the access control settings for the SOFTWARE key.  
20. Click OK back at the permissions for SOFTWARE dialog. 

 
Proxy firewall installation problem 
Please send an email describing the issue to Layouthelp@AdvancedPCB.com. 
   
Directory of the design 
The software by default is installed at C:\Programs(x86)\Advanced Circuits\PCB Artist  
 

• In Windows 10 and 11 t files in that directory to be stored in a way that allows all 
other files including libraries are placed at C:\Users\Public\Documents\PCB Artist 

 
Other operating systems 
At this time only Windows systems from Windows Vista to Windows 11 are supported.   

• Some users are successfully using PCB Artist on the following operating systems 
with emulation software: 

o Macintosh using Parallels 
o Macintosh using Virtual PC 
o Ubuntu Linux using Wine 

 
Downloading PCB Artist through www.Download.com   
To ensure the latest version of the PCB Artist software is downloaded, Download it from 
the AdvancedPCB.com website. 
Contact PCB Artist support at Layouthelp@AdvancedPCB.com if you are still unable to 
download from this location. 

mailto:layouthelp@4pcb.com
https://www.advancedpcb.com/en-us/tools/pcb-artist-software/
mailto:Layouthelp@4pcb.com


 

 

 

Assembly                                                                                                                                       
Back to the Menu 

 
Optimizing the design for Advanced PCB Assembly Services 
If you right click on a component and choose Properties from the right-click context 
menu.  Then click on the Values tab.  From there you can enter values for the 
Manufacturer, Manufacturer Part Number, Distributor, and Distributor Part Number. 

• If Advanced PCB is providing a turnkey service of ordering the parts for an order, 
this information will tremendously reduce the amount of time spent ordering the 
parts. This would eliminate a large amount of redundant communication with the 
customer. 

• If the customer is providing the kit for the assembly, these populated values will 
make it easier for the customer to have a comprehensive list of exactly what to 
order.   

• PCB Artist will create files that help to optimize the assembly process.  These 
files are embedded in the board design and only available for Advanced PCB 
Assembly. 

• Do not put via holes inside surface mount lands, unless there is a critical 
electrical reason. 

• Always click on the Thermals Pads checkbox in the copper pour dialog when 
pouring copper.  Via holes can be directly connected to the plane and is a 
separate checkbox option. 

 
Getting a quote for board assembly 
Contact your region’s sales representative for information regarding board assembly.   
  
Creating a Bill of Materials (BOM) and/or Component Positions Report 
Assembly reports may be found under Tools>Reports.  They are available in text or 
Excel formats.   It is up to the board designer to review and correct these reports for 
parts information and placement. 

 
Adding fields to the BOM 
One will be able to add new fields by creating them as Values first on the component. 

 



 

 

 

Under Output>Reports, it is best to copy the BOM report then edit it.  In the new bill of 
materials report options select the edit button. In the next window select edit again. It is 
here that one may add the value, label it and have it appeared on the BOM. Select Value 
in the Field and the title of the Value in the Caption. Because this is a Value, the Value 
area will no longer be grayed out. In the Values area select add, then select the new 
value from the list. These values will only appear if the components on the board already 
have the listed value within their definitions. 

 



 

 

 

Best Practices                                                                                                                               
Back to the Menu 

 

• The file with the Tilde “~” in front of it is the security backup.  This is not 
your actual working file.  The interval of how often it gets backed up is from 
Settings>PCB Configuration.  If you set that to zero, it will not perform a backup, 
which is not recommended. 

• Do not use Delete to remove tracks for redrawing.   
o Delete will remove the track and its rats nest connection.  Delete is 

intended to completely remove the connection from the netlist.   
o To Remove the track, but not the connection: 

▪ Select a segment of the track 
▪ Right click on it and choose Nets>Unroute Track Segments (or 

Unroute Track Path) from the right-click context menu.  The track 
will be replaced with an unrouted rats nest connection.  

• It is not recommended to use Undo to remove the results of the autorouter.   
Use Tools>Unrout Nets>All Nets. 

• Be careful when joining nets. 
o A warning will appear such as this: 

•  

o Be sure that the new net created by both is the correct one.  This 
depends upon which net you were drawing with.  Cancel and redraw your 
connection from the other net to make the resultant net the desired one. 

o Once the net is joined, it cannot be split.  The smaller net must be deleted 
and redrawn. 

• Avoid overlapping copper pours where possible. 
o Overlapping copper pours confuse the netlist. 
o If click down on the wheel of a wheel mouse, it will pan across the screen 

while dragging different types of drawings including polygons.  This 
makes drawing overlapping polygons unnecessary. 

• Do not use copper pours for contact lands. 
o They will not have a soldermask clearance.  They will be covered by 

soldermask, which is very hard to scrape off the contact. 
o Options: 

▪ Reconstruct them as surface mounts. 
▪ Create a clearance of a filled rectangle or polygon on the 

soldermask layer. 



 

 

 

• If your surface mount is colored gray, it requires a crucial edit. 
o Go into the Properties of the object and change them from layer [All] to 

layer [Top]. 
o If the surface mount is part of a component, the edit must be done in the 

PCB Symbol editor. 
o This assumes that the default color settings are being used. 

• Make sure your power and ground nets are properly defined in 
Settings>Nets as Power or Ground in the Class Column. 

o Power and ground traces usually need to be thicker than signal traces.  
All nets are classified as signals until the designer changes them to 
Power or Ground Class. 

• Always create a new library for any parts you create or modify. 
o If a future version of PCB Artist needs complete installation, any existing 

pre-packaged libraries are automatically overwritten, and all parts will be 
lost. 

o All part creation documentation in this document describes the process of 
making a new library for your part. 

• In Settings>Spacings, never change the Board row to less than .020” or the 
Shape row to less than .010”. 

o Those settings are not only for Design Rule Checks but also provide rules 
for how copper pours are created. 

• Do not create parts with the same name as any other part in any other 
library. 

o The system acquires parts in a hierarchy of libraries that are searched for 
when symbols are updated in the PCB or Schematic.  If the other part 
with same name in the other library is located first, it will now be 
associated to that symbol. 

• Do not add Vias inside Surface Mount Lands. 
▪ Many designers add vias inside surface mount lands as a way of 

conserving space in a design.  This creates greater difficulty and 
lower quality solder joints in assembly.  This practice is not 
recommended unless necessary for electrical purposes. 

• Always use Thermal Pads in Copper Pours for component holes. 
▪ Regardless of heat sink needs, always use thermal pads in copper 

pours for component pads.  Thermals pads are not necessary on 
vias.  Directly connecting lands to the planes will cause assembly 
problems are poor quality solder joints. 

 

• Preventing accidental edits. 
o Making layers or object types unselectable is possible from View>Colors.  

Go to the Layered Items tab. 
▪ The Selectable row locks objects by changing the cell from Yes to 

No with a double click of the mouse button. 



 

 

 

▪ The Selectable column locks objects for specific layers by double 
clicking the cell from Yes to No. 

▪ Individual objects can be locked from editing by selecting that 
object, right-clicking on it, and choosing Fix Item.  This will prompt 
a dialog box asking for confirmation if an edit is attempted on a 
specific object. 

 
 

• Create a pdf file. 
o One may create a pdf file by printing it in a pdf format.  This can be done 

by finding a free pdf generator program online and installing it.  The 
option to create a pdf will be listed as a printing option beside the other 
printers under File>Print Setup>Printer drop down. 

 

• Do not create features with a 0 (Zero) dimension 
o Rounded rectangular pads with a 0 radius for the corners, tracks with a 0 

mil width, and various other features that have a zero dimension do not 
process well outside of PCB Artist, and will cause issues with the 
production of the board.  It’s best to avoid using 0 in any dimension that 
may require a positive value. 

 

• Order and Submit Boards through PCB Artist 
o Advanced PCB has numerous websites for ordering and uploading files.  

With PCB Artist, boards are ordered and submitted through the software 
itself.  These are accessible through the options Output>Submit now, and 
the Order Now option on the Menu.  More may be found about ordering 
through PCB Artist Here in this document. 

 

• Missing PCB Design Menu 
o Sometimes the PCB Design Menu will be missing.  To retrieve the menu, 

right click on the gray area located right of the Cursor Icon.  This will show 
a pop-up of all available menus.  Check the PCB Design option in the pop 
up.  If the PCB Design Menu is already checked.  Uncheck the option and 
recheck it.   



 

 

 

• Don’t Ignore Pop up Boxes 
o As easy as it is to ignore a box that has popped up, one really shouldn’t.  

Many of these pop ups are warnings that will directly affect your design 
and may never appear again if it regards a particular feature being 
placed.  Carefully read the error and decide if you should proceed with 
what is causing the pop up to appear. 

 

• 



 

 

 

Where to find a list of Hotkeys in PCB Artist. 
Hotkey reports may be produced from the Report link under Help>Shortcut Keys. 
 

 
 

If you have a new question, please send it to Layouthelp@AdvancedPCB.com 
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